First off this is a user forum, no members of development look here.
Secondly:

apt policy xfce4-notes-plugin
xfce4-notes-plugin:
Installed: 1.9.0-1
Candidate: 1.9.0-1
Version table:
...