You're actually running 'mate-terminal', the default in Ubuntu-MATE. Replace all the commands above for the proper name to confirm version.