Search:

Type: Posts; User: dkosovic; Keyword(s):

Search: Search took 0.01 seconds.

  1. [ubuntu] Re: Cannot connect VPN type L2TP over IPSec

    Regarding the "payload type ID_V1 was not encrypted" error, see :

    https://kevinlocke.name/bits/2017/08/26/strongswan-sonicwall-payload-type-id-v1-was-not-encrypted/

    If the...
  2. Replies
    1
    Views
    2

    [ubuntu] Re: L2TP setup on Ubuntu 18.04 LTS

    Here are the mappings from what your VPN provider provides to what NetworkManager-l2tp has:


    Server Address : Gateway
    username and password : same.
    IPsec pre-shared key : same (find it in...
  3. [SOLVED] Re: l2tp error - VPN connection: failed to connect: 'invalid ipsec-gateway-id '

    Glad to hear you got it going.

    It's not different versions, but different IPsec services, 3des-sha1;modp1024 syntax with the semicolon is for libreswan, while the 3des-sha1-modp1024 syntax is for...
  4. [SOLVED] Re: l2tp error - VPN connection: failed to connect: 'invalid ipsec-gateway-id '

    Looks like strongswan (charon) is having issues and network-manager-l2tp killed it after a 10 second timeout, it didn't even get to xl2tpd's L2TP connection

    Have a look at the "Issue with VPN...
  5. [SOLVED] Re: l2tp error - VPN connection: failed to connect: 'invalid ipsec-gateway-id '

    In your latest log output I don't see anything that has do with network-manager-l2tp, strongswan or xl2tpd.

    I'm guessing you are seeing a "udp_xmit failed ... with err=-1:No such device" error...
  6. [SOLVED] Re: l2tp error - VPN connection: failed to connect: 'invalid ipsec-gateway-id '

    If I'm reading that warning correctly, for the Gateway ID in the IPsec Options dialog box, you entered 'ipsec-gateway-id' ?

    The Gateway ID is the peer's IP address and is primarily used when...
  7. [ubuntu] Re: How to set up L2TP/IPsec VPN on Ubuntu 17.10

    For the NT Domain, you didn't enter TTU

    All of the proposals the TTU VPN server (vpn.ttu.edu) is offering contain weak algorithms, so newer versions of strongswan and libreswan need the phase 1...
  8. Replies
    3
    Views
    4

    [all variants] Re: VPN L2TP with IPSec failing

    Most of the dependencies you installed are for building the network-manager-l2tp source code, but are harmless for running.

    You only need the following strongswan packages :


    strongswan
    ...
  9. Replies
    8
    Views
    9

    [ubuntu] Re: Ubuntu 17.10 L2TP VPN

    Forgot to mention, unless you still have WinXP or earlier VPN clients, there is no reason to only offer the broken 3DES algorithm with L2TP/IPsec servers.
  10. Replies
    8
    Views
    9

    [ubuntu] Re: Ubuntu 17.10 L2TP VPN

    The two most common reasons why network-manager-l2tp doesn't allow you to connect to a VPN server:

    1. Issue with not stopping system xl2tpd service, see the README.md file :
    ...
  11. Replies
    8
    Views
    9

    [ubuntu] Re: Ubuntu 17.10 L2TP VPN

    Is there something wrong with the version of network-manager-l2tp that ships with Ubuntu 17.10?

    https://packages.ubuntu.com/artful/network-manager-l2tp-gnome

    Ubuntu 17.10 ships with both...
Results 1 to 11 of 11