Fedora 28 went end of life nearly two years ago, on 28 May 2019. I haven't used Fedora for years but my guess is that the repository for Fedora 28 is closed and that is the reason for the error...