Same here, also looking for the 2.6.32-34 version.

Does anyone know a suitable workaround?

I have been using the "sudo apt-get install linux-alsa-driver-modules-$(uname -r)" solution ever since...