12.10 is out of support. Better to begin with a fresh install of 14.04.1 or 14.10.