Search:

Type: Posts; User: ubfan1; Keyword(s):

Search: Search took 0.05 seconds.

  1. [SOLVED] Re: CUDA 12.1.1 Nvidia 530 Ubu 22.04 LTS Package dependency problem on install

    You can use the thread tools at the top of the page to mark this as SOLVED. Good to see you got this working.
  2. [SOLVED] Re: CUDA 12.1.1 Nvidia 530 Ubu 22.04 LTS Package dependency problem on install

    Do not change your gcc (and g++) system defaults. For Ubuntu 22.04, /bin/gcc (and /bin/g++) should be links to the 11 version(s). The Nvidia module will use the correct version needed as long as the...
  3. [SOLVED] Re: CUDA 12.1.1 Nvidia 530 Ubu 22.04 LTS Package dependency problem on install

    The Nvidia instructions say to put the .../cuda/bin at the beginning of the PATH, not the end. At the beginning, you could easily select to override gcc with a link to whatever you wanted, but that...
  4. [SOLVED] Re: CUDA 12.1.1 Nvidia 530 Ubu 22.04 LTS Package dependency problem on install

    Ubuntu 22.04 uses gcc 11.3 for building the system libraries. gcc-12 may be needed to build modules for kernel 6.5, which used the gcc-12, but not for CUDA samples, which will pick up the system...
  5. [SOLVED] Re: CUDA 12.1.1 Nvidia 530 Ubu 22.04 LTS Package dependency problem on install

    Good to see you got the video set up. The 6.5 Nvidia/gcc-12 problem was probably just a forgotten dependency on the old dkms package 22.04 is using. The newer dkms packages seem to have all the...
  6. [SOLVED] Re: CUDA 12.1.1 Nvidia 530 Ubu 22.04 LTS Package dependency problem on install

    A recent fix seems to have let the nvidia module build for kernel 6.5 succeed without having to have the /bin/gcc link changed from the default of gcc-11 (as long as gcc-12 is present). Those held...
  7. [SOLVED] Re: CUDA 12.1.1 Nvidia 530 Ubu 22.04 LTS Package dependency problem on install

    There was a recent fix on getting the gcc-12 compiler for the compilation of the Nvidia module (assuming you are running a 6.5 kernel). If you are running 6.5, (cat /proc/version to see which gcc was...
  8. [SOLVED] Re: CUDA 12.1.1 Nvidia 530 Ubu 22.04 LTS Package dependency problem on install

    $ ubuntu-drivers install foo:bar
    All the available drivers are already installed.

    Names are critical, try sudo ubuntu-drivers install nvidia-driver-535

    Get the available drivers from...
  9. [SOLVED] Re: CUDA 12.1.1 Nvidia 530 Ubu 22.04 LTS Package dependency problem on install

    I have 29 packages with nvidia and 535 in the dpkg -l output (half 32 bit versions). Still, I'm not sure you got everything you need just installing the two packages you mention. Try ubuntu-drivers...
  10. [SOLVED] Re: CUDA 12.1.1 Nvidia 530 Ubu 22.04 LTS Package dependency problem on install

    Yes, my current latest CUDA is 12.1, and it was installed after the Nvidia driver which was current at the time. Every few releases I install the latest CUDA, and maybe delete an old one, keeping a...
  11. [SOLVED] Re: CUDA 12.1.1 Nvidia 530 Ubu 22.04 LTS Package dependency problem on install

    I gave up on Nvidia's CUDA deb installation awhile back -- when a normal video driver update wanted to delete all the CUDA files! Totally messed up dependencies. Get your system running with your...
Results 1 to 11 of 11