The version prior to Ubuntu 23.04 was version Ubuntu 22.10. Support for Ubuntu 22.10 ended three weeks ago. No more security patches. Migrate to a newer release of Ubuntu.

Or perhaps you meant...