For the specific error you're getting, you'll need to run:


sudo apt-get install libfreetype6-dev

You'll get the development version of the freetype library.
You might get more errors when...