I know you don't want to upgrade because your program, but you're allowing hackers to easily exploit your system because you're running a no longer updated version of Ubuntu. as others have said, ...