Also, the version of Ubuntu you are using has expired, which makes it harder for people to help you: the people who have answers are not running 10.04.