AFAIK Ubuntu 24 ships with Python 3.11 or 3.12, which will predictably break any incompatible software.

You could use miniconda to run an earlier, compatible version of Python; this is what I do...