PDA

View Full Version : [ubuntu] [SOLVED] Dell modem problem - Intrepid



Michael Dooley
November 30th, 2008, 03:44 AM
I have a Dell D610 Latitude that I installed Intrepid Ibex on a week ago. I visited a friend with cable access and updated the installation and added a few programs that I ordinarily use in my Hardy desktop set-up. One of the programs was gnome-ppp which I use as a dialer in order to connect with the internet. However I am unable to connect on the Intrepid machine. Looking at the log that gnome-ppp generates during its connection session, I saw the following:


--> Ignoring malformed input line: ";Do NOT edit this file by hand!"
--> WvDial: Internet dialer version 1.60
--> Cannot set information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATM1L1DT8729811
--> Waiting for carrier.
ATM1L1DT8729811
CONNECT 460800
User Access Verification
Username:
--> Carrier detected. Starting PPP immediately.
--> Unable to run /usr/sbin/pppd.
--> Check permissions, or specify a "PPPD Path" option in wvdial.conf.
% Username: timeout expired!
NO CARRIER
--> No Carrier! Trying again.
--> Maximum Attempts Exceeded..Aborting!!

So it connects but then fails to provide a "useable" connection. I looked at the pppd permissions in both Hardy and in the new Intrepid install and saw no obvious differences. I tried inserting a path line (path = /usr/sbin/pppd) into the wvdial.conf file and it apparently made no difference either.

Do you have any idea what I might try next?

Here's my wvdialer.conf file if it might be useful:


[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = Analog Modem
Baud = 460800
New PPPD = yes
PPPD path = /usr/sbin/pppd
Modem = /dev/modem
ISDN = 0
; Phone = <Target Phone Number>
; Password = <Your Password>
; Username = <Your Login Name>

--
michael

Discombobulated
December 2nd, 2008, 03:01 AM
Try 'sudo wvdial' in terminal.

If it's *only* the permissions, that should be a workaround.

Michael Dooley
December 2nd, 2008, 06:48 PM
Thanks Discombobulated - sudo wvdial worked. I made sure by trying it several times and also trying gnome-ppp without sudo which got a permissions problem as in my original post. Now I'll have to figure out why I, as the only user, have to go through root in order to connect via dial-up.

I'll mark this as "solved" for the time being and post a follow up when I find a more permanent solution.

Maybe I need to be a member of the group "dip" - see the permissions on the executable file PPPD at /usr/sbin/pppd? I'll work on it.

Thanks again-

Discombobulated
December 3rd, 2008, 12:17 AM
No problem, Michael - glad I could help.

I was having the same problem as you, having just done a fresh 8.10 install.

A couple of other pointers for the benefit of others (I note you're already aware of them)...

Check your username is a member of the group 'dip':

System > Administration > Users and Groups > [Unlock] > Manage Groups > select group 'dip' > properties > tick your username

Then set appropriate permissions:

(Open a terminal window and enter the following commands):

sudo chown root:dip /usr/sbin/pppd
sudo chmod 4754 /usr/sbin/pppd
sudo chmod 777 /etc/ppp/pap-secrets
sudo chmod 777 /etc/ppp/peers

I did all this and still needed 'sudo' to get wvdial to work...

I had just resigned my self to a life of sudo-masochism, when it occured to me to install gnome-ppp (from synaptic), and Hey Presto! gnome-ppp connects fine without entering my (system) password.

You could just try (re) installing gnome-ppp first without the rest of it - if it works, post back here.

(I'm sure gnome-ppp was installed by default in previous releases).

Another thing I did in the middle of all this (which might have had some effect) was to upgrade to kernel 2.6.27-10-generic - to get that:

Synaptic > settings > repositories > updates > tick 'proposed updates'

Then run update manager.

(I had to do THAT to stop the USB wi-fi borking! #-o )

Michael Dooley
December 5th, 2008, 01:14 AM
Check your username is a member of the group 'dip':

System > Administration > Users and Groups > [Unlock] > Manage Groups > select group 'dip' > properties > tick your username

Tried this but could not locate user group "dip".


Then set appropriate permissions:

(Open a terminal window and enter the following commands):

sudo chown root:dip /usr/sbin/pppd
sudo chmod 4754 /usr/sbin/pppd
sudo chmod 777 /etc/ppp/pap-secrets
sudo chmod 777 /etc/ppp/peers

I did all this and still needed 'sudo' to get wvdial to work...

Me too. None of the above commands worked.


I had just resigned my self to a life of sudo-masochism, when it occured to me to install gnome-ppp (from synaptic), and Hey Presto! gnome-ppp connects fine without entering my (system) password.

I tried this too. No workee.


Another thing I did in the middle of all this (which might have had some effect) was to upgrade to kernel 2.6.27-10-generic

I haven't tried this yet but I may do the upgrade this weekend in hopes of getting gnome-ppp to work as it should. I'll let you know what happens. Thanks Dis.

--
michael

Michael Dooley
December 15th, 2008, 02:09 AM
What a long strange road.

I upgraded to kernel 2.6.27-10-generic last weekend and that didn't seem to make things better. I still had to use sudo to get wvdial to connect. Without "sudo", I would get this message:


ATM1L1DT8729811
CONNECT 460800
User Access Verification
Username:
--> Carrier detected. Starting PPP immediately.
--> Unable to run /usr/sbin/pppd.
--> Check permissions, or specify a "PPPD Path" option in wvdial.conf.

This afternoon, I removed gnome-ppp and then reinstalled it - my configuration file returned even though I had wanted gnome-ppp removed *completely*. I actually don't know if this had any effect at all but I wanted to follow a procedure that might get my permissions problem to go away. More was required.

I then went through the command sequence below once again that Discombobulated previously recommended, but this time after the kernal upgrade.


sudo chown root:dip /usr/sbin/pppd
sudo chmod 4754 /usr/sbin/pppd
sudo chmod 777 /etc/ppp/pap-secrets
sudo chmod 777 /etc/ppp/peers


That seems to have done the trick - I can now use gnome-ppp without seeking root privledges. Wvdial also works without being superuser.

What a relief. Now all I need to do is get the Dell Conexant winmodem to connect at a faster speed. Just being able to connect without a work-around is great.

Thanks Dis.

--
michael