View Full Version : [ubuntu] How to connect a USB printer to a Router (Fritz Box)

November 29th, 2008, 06:10 PM

I would like to know how to connect a printer to a Router Fritz Box. I have a Fritz Box 7270 which has a USB port. In windows it works (Which I don want to use).

Under www.avm.de (fritz Box) they have mentioned to use option "Raw TCP" and port 9100.

When I go under System>Administration>Printing. I choose new printer and then there the following options.

LPT #1
Serial Port #1
AppSocket/Hp JetDirct
Internet Printing Protocol (ipp)
LPD/LPR Host or Printer
Windows Printer via Samba

I have no clue which one to take. I have tried ipp but no luck. I have a Samsung ML1610.

December 2nd, 2008, 12:20 AM

You have to choose "AppSocket/Hp JetDirct" and enter the IP Address of your FritzBox! router. the port is 9100, but i assume it is already entered in that Port-field.

if there are any problems, just let me know :)



December 2nd, 2008, 10:23 AM
Hello thehayro,

thx for your reply, I have tried it and it gives a message printer not ready and network busy. what should be the location.

screenshot attached.

May 24th, 2009, 01:40 PM
This set-up worked for me great (Canon Pixma iP5000), but I noted with my previous attempts of entering the correct setting, the printer had disabled itself. Perhaps you could verify the Printer is still enabled, if it is - Disable it and re-Enable it.

I also went to the USB device page of the Fritz!Box, enabled Remote access for USB devices and Unticked it again - then all seemed to work - I am not sure if this has any impact, but on my previous installation of Ubuntu, I also performed this action, and also thereafter it worked!! - It may be that the Fritz!Box requires some kind of USB reset, and this is activated by this action.


May 17th, 2010, 10:10 AM
Go to: System - Administration - Printing

Klick: New

Choose: Network Printer

AppSocket/HP JetDirect
Host: fritz.box
Port: 9100

Then choose the right printer. You should use the same printer driver that you would when connecting the printer via USB to Ubuntu.

For my Samsung ML-2010 this worked perfectly.