View Full Version : [ubuntu] DPKG error need help please

November 27th, 2008, 11:57 PM
Hello I was searching the forums on this and found a couple of stuff but none really solved my problem.

I Just installed Ubuntu within XP since I am a first time linux user and have figured out almost enough to replace xp :)

but now i can't update or add new programs

I get the same error message when trying to do both.

" E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report. "

the other dpkg error i found on this forum was due to boot drive being filled up but mine still has 5GB left so i dont think that is the problem

Can anyone help?


November 28th, 2008, 12:00 AM
Open a terminal and type:

sudo dpkg --configure -a


November 28th, 2008, 12:00 AM
Open a Applications-->Accessories-->Terminal and type:

sudo dpkg --configure -a

Just like it says in the error message.


November 28th, 2008, 12:04 AM
Oops i forgot to put that half of the error up.:lolflag:

after doing that it comes up
"dpkg: ../../src/packages.c:221: process_queue: Assertion `dependtry <= 4' failed.
and my fail train continues...

November 28th, 2008, 06:28 PM
I"m having the same problem and did as directed, but received "no command found" Help!