PDA

View Full Version : [ubuntu] Can't configure nic



mikee55
November 27th, 2008, 05:37 PM
Hi, I have 2 NIC's. eth1 connects to my cable dsl and works fine, I can surf the web. eth0 connects to my LAN. I've installed Firestarter, but it says device eth0 is not ready. It says I need to check device settings and make sure my internet connection is active.
Network Configuration doesn't help either?

Thank you,
Mike

eder.apt-get
November 27th, 2008, 06:15 PM
Do you really need Firestarter? I mean, itīs a gui, but you can do IP masquerading without installing anything:
http://en.tldp.org/HOWTO/IP-Masquerade-HOWTO/

Anyway, maybe you might check this forum: http://www.linuxquestions.org/questions/linux-networking-3/ubuntu-box-as-router-319188/
It may give you a way to go..
(Iīve found tons of answers while googling "firestarter eth device not ready")

mikee55
November 27th, 2008, 06:45 PM
Hi, I can't believe everything is so complicated? Why do you need to type in all that just to do a Masquerade, in M$XP all I did was tick the shar e this connection with other computers on the internet connected card, aand job done. Why should it be so hard in Linux?

Mike

mikee55
November 27th, 2008, 07:32 PM
Tried Masquerade, nothing happens???

Mike

mikee55
November 27th, 2008, 10:10 PM
Anyone, please?

mikee55
November 28th, 2008, 02:58 PM
Where's everyone gone??????????????????????????????

Ayuthia
November 28th, 2008, 03:18 PM
I was thinking that you had to assign an ip address for eth0. Did you do that already? I could be wrong about this though (It might apply to dhcp3-server--I can't remember).