PDA

View Full Version : [all variants] AlwaysVPN slow on Ubuntu



Kheops_74
November 27th, 2008, 03:55 AM
Anybody tried http://alwaysvpn.com/. It's a linux replacement for Hotspot Shield. I install it and it works. I can browse the Internet.

The speed is not good. I get around 250 kbps on Ubuntu. The same software on Windows XP (in Virtualbox) gets 1400 kbps. It's far away from Hotspot who gets 3900 kbps in Virtualbox.

Any idea where to find tips to get more speed?

Thanks

K

Kheops_74
November 28th, 2008, 01:17 PM
I did a lot of tests. Best speed : 900 kbps. It's not easy to find the root of the problem.

Any OpenVPN guru on Ubuntu?

K

Kheops_74
November 29th, 2008, 11:20 PM
Ok no guru. Maybe i'm the only one to use it on earth. If not, post these information:

OpenVpn version : 2.0.9
Script used : alwaysvpn-tcp-Compatible.conf
Speed using http://www.speakeasy.net/speedtest/ (Seattle) without vpn : 3157 / 464
Speed using http://www.speakeasy.net/speedtest/ (Seattle) WITH vpn : 540 / 254


alwaysvpn-tcp-Compatible.conf

####
## AlwaysVPN linux TCP client configuration version 1.0
####
client
dev tap
proto tcp-client
remote cluster1.alwaysvpn.com 443
remote cluster1.alwaysvpn.com 80
remote cluster1.alwaysvpn.com 22
remote cluster2.alwaysvpn.com 443
remote cluster2.alwaysvpn.com 80
remote cluster2.alwaysvpn.com 22
redirect-gateway def1
resolv-retry infinite
nobind
persist-key
persist-tun
shaper 50000
ca /etc/openvpn/alwaysvpn_ca.crt
cert /etc/openvpn/client_grp2.crt
key /etc/openvpn/client_grp2.key
ns-cert-type server
tls-remote alwaysvpn_s
tls-cipher DHE-RSA-AES256-SHA:DHE-DSS-AES256-SHA
cipher BF-CBC
comp-lzo
verb 3
#up /etc/openvpn/update-resolv-conf
#down /etc/openvpn/update-resolv-conf
# user nobody
# group nogroup
# tun-mtu 1400
# fragment 1300
# mssfix 1300

resolv.conf

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
# DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 208.67.222.222
nameserver 208.67.220.220

john_navarro
November 30th, 2008, 05:00 AM
Have you looked at your /var/log/syslog file while your VPN is connected? If you see packet buffering or reordering messages then your MTU is set too large.

Kheops_74
November 30th, 2008, 02:57 PM
I don't see special message in syslog.

Here

Nov 30 08:44:59 ?-desktop avahi-daemon[4959]: Joining mDNS multicast group on interface tap0.IPv4 with address 10.19.96.29.
Nov 30 08:44:59 ?-desktop avahi-daemon[4959]: New relevant interface tap0.IPv4 for mDNS.
Nov 30 08:44:59 ?-desktop avahi-daemon[4959]: Registering new address record for 10.19.96.29 on tap0.IPv4.
Nov 30 08:44:59 ?-desktop avahi-daemon[4959]: Withdrawing address record for 10.19.96.29 on tap0.
Nov 30 08:44:59 ?-desktop avahi-daemon[4959]: Leaving mDNS multicast group on interface tap0.IPv4 with address 10.19.96.29.
Nov 30 08:44:59 ?-desktop avahi-daemon[4959]: Interface tap0.IPv4 no longer relevant for mDNS.
Nov 30 08:44:59 ?-desktop avahi-daemon[4959]: Joining mDNS multicast group on interface tap0.IPv4 with address 10.19.96.29.
Nov 30 08:44:59 ?-desktop avahi-daemon[4959]: New relevant interface tap0.IPv4 for mDNS.
Nov 30 08:44:59 ?-desktop avahi-daemon[4959]: Registering new address record for 10.19.96.29 on tap0.IPv4.
Nov 30 08:45:00 ?-desktop avahi-daemon[4959]: Registering new address record for fe80::4835:86ff:feac:a7a3 on tap0.*.
Nov 30 08:45:09 ?-desktop kernel: [179107.680018] tap0: no IPv6 routers present

I don't know what is MTU. I will Google this.
The other thing is the "no IPv6 routers present" message. I will Google this as weel.

Thanks.

K

Kheops_74
December 1st, 2008, 01:27 PM
I disable ipv6 and check the MTU (it's1500). It didn't help. Maybe it's a problem of AlwaysVPN site.

Can someone confirm?

K

wild_oscar
December 11th, 2008, 12:44 PM
I disable ipv6 and check the MTU (it's1500). It didn't help. Maybe it's a problem of AlwaysVPN site.

Can someone confirm?

K

I tried it for some minutes, to watch hulu. Internet browsing was slower, didn't even manage to run a video on hulu...

Kheops_74
December 24th, 2008, 05:32 PM
I give up. I'm sure the problem come from their server. Good idea but too slow to be useful. Hotspot shield still rules. Hope they will bring it to Ubuntu one day.

K