PDA

View Full Version : [ubuntu] problem after enabling laptop_mode



Ryan2009
November 25th, 2008, 07:09 AM
Running fresh install of Ubuntu 8.10. I notice with laptop_mode enabled that my hard drive is spinning up and down quite a lot.

Just simple browsing whenever I go from one page to another it spins up then down again.

Anyone have any ideas on how to fix this so it doesn't power on and off so much?

I also notice that when the hdd does spin up, the computer stops responding for about half a second.

Using a Dell Latitude D620.

Ryan2009
November 26th, 2008, 04:58 AM
anyone?

iggykoopa
November 26th, 2008, 05:34 AM
If your using firefox (you said browsing) it's probably the cache, you can try turning off the cache if you want. Go to about:config and set this network.http.use-cache = false or you can try out a python script I wrote(if your willing to test it out, I know it works on my machine) http://www.planetwatt.com/index.php?name=PNphpBB2&file=viewtopic&t=51 here. It loads the firefox cache into a ramdisk then copies it back when you close firefox. Just follow the instructions on that page.

Ryan2009
November 27th, 2008, 12:11 AM
I disabled the network.http.use-cache (set to false) and the hdd still spins up and spins down when I am browsing. I don't have any other programs running.

not sure how to find out what is polling the hdd.

is there any way to increase the duration before the hdd goes idle?

jpkotta
November 27th, 2008, 02:04 AM
This will start logging all the processes that hit the hard drive.

echo 1 | sudo tee /proc/sys/vm/block_dump
tail -f /var/log/messages

There are tips at lesswatts.org about how to minimize hdd activity.