View Full Version : [kde] Microsoft Wireless Mouse not working

November 24th, 2008, 08:52 PM
Ever since an update two or so weeks ago, I and a friend have both been experiencing the same problem with our Microsoft Wireless Optical Mice and sidux. I run an HP and she runs a Dell. Whenever we plug in the USB receiver for the mice, the laptop recognizes the mouse. However, the cursor then proceeds to drag itself down to the bottom of the screen and can only move in the y-axis. Any movement of the mouse cursor to another location results in the same downward motion. We have tried reinstalling drivers and other various tweaks, but the issue does not seem to have resolved itself. Does anyone know a fix to this?

November 24th, 2008, 11:30 PM
No detailed knowledge of this particular problem, but it may help if I say that this effect was typical of old manual mice with a dirty mechanism - you haven't changed the surface you normally use, have you? Also happens with run down batteries. Does it work ok under Windows? If not, try completly uninstalling & reinstalling under windows - this might even help if problem only in kde. It may reset the mouse some way - I have had this with a keyboard freezing in Ubuntu being reset by reloading in Windows.

November 25th, 2008, 09:39 PM
Nope, the table surface is the same, and I'm using a brand new battery. It works beautifully under Windows on my other laptop, but for some reason it doesn't seem to want to play nice in KDE. (for the record, it doesn't work under GNOME either?)