View Full Version : [kubuntu] 64bit 8.04->8.10 fine until reboot, now stops at login backdrop

November 24th, 2008, 05:17 PM
Upgrading my main computer (AMD 64 bit) from Kubuntu 8.04 to 8.10, everything was going fine until I was asked to reboot.

The system went through a disk check, which found something that needed fixing after about 30 minutes of check (5 seconds wasn't enough to read a screenfull of information before the system auto-restarted)

After this the system got as far as displaying the black and grey swirly background of the login screen, but is not displaying anything on this background at all. I only know it is the login background from having previously upgraded my Intel centrino 32-bit laptop without a hitch.

I've tried restarting X via ctrl+alt+backspace but this just gets me to the same position. ctrl+alt+del does nothing.

I can ctrl+alt+F1 to a terminal and do everything in there that I know how to do in a terminal. I've done sudo shutdown -r now in here to restart the machine and gone through three normal boots and a recovery boot, all getting to the backdrop and no further.

The recovery console dpkg didn't find anything missing or in need of repair, but did remove to obsolete linux-headers packages. None of this has got me beyond the background.

all my data appears fine on the hdd. I can ssh to a remote server from the ctrl+alt+F1 terminal, so the network is working.

It appears to be just an X problem, but I'm no expert.

The important hardware specs are at http://sucs.org/~cmckenna/newpc although the case and monitor are different, and it's also running a floppy drive, a second dvd-rw and a cd-rw drive that I inherited.

All help appreciated!


November 24th, 2008, 05:43 PM
update: after leaving it a few minutes I noticed that the process "kdmgreet" was gradully using up more and more CPU time.

I've killed that, but it has not had any impact at all, except the load average is now hovering around 0.10 (with most of that being "top") whereas it was a 1.02 and climbing previously.


November 24th, 2008, 07:41 PM
another update:
manually launching gdm leads to a message saying another X session is running do I want it on a different tty
I say yes to that.
I get a dialog telling me that :0 is busy and it's started on :1
I get a dialog telling me that the greeter application is crashing.
I say ok to that, it returns to tty1 for ~5 seconds, then returns me to the same dialog.
this happens a total of 5 times
gdm starts, and I can launch gnome from it without a problem.
I try launching kde from it and the post-login animation goes without a hitch until the final icon (the large K)
This stays active for a long while (~2 minutes)
then I get a black screen with a white mouse pointer and then the system hangs.

I'm about to try uninstalling kdm and then reinstalling it.

November 24th, 2008, 08:36 PM
Nope, that hasn't made a blind bit of difference.

gnome works fine, KDE doesn't.

Any help really appreciated.

November 25th, 2008, 03:09 AM
nothing? not a single idea from anyone?

November 25th, 2008, 04:43 PM
no thanks to anyone here I solved this by completely unistalling KDE and reinstalling it. Not impressed.