View Full Version : [ubuntu] r u close to Uni of Sydney? willing to meet up & help install a software??

November 24th, 2008, 03:05 PM

I am a student at Uni of Sydney Australia. I have just switched over to ubuntu. I need to install a small educational software on my system....it is called cmap (concept map)..it is a free software for creating a pictorial representation of ideas and concepts (available at cmap.ihmc.us)... it is an .exe file and the download site says that it is for linux.. but I cant install it.

Is there anyone out there in Sydney who can help me with that.... if you want I can come over to your place.

please PM me.


Amer Khan
PhD Student
Uni of Sydney

November 24th, 2008, 03:25 PM
did you follow this link? http://cmap.ihmc.us/download/installs/CmapTools/Linux/LinuxCmapTools_v4.18_06-09-08.zip

its clearly a zip file, im downloading it right now to see whats inside.. and maybe give some instructions to follow..

November 24th, 2008, 03:29 PM
did you follow this link? http://cmap.ihmc.us/download/installs/CmapTools/Linux/LinuxCmapTools_v4.18_06-09-08.zip

its clearly a zip file, im downloading it right now to see whats inside.. and maybe give some instructions to follow..

Thanks eldragon for your help. yes it is a zip file and it is just sitting there on my desktop refusing to budge!!! I tried to open it using the synoptic manager etc. but it refuses to acknowledge the file!!


November 24th, 2008, 03:31 PM
Check out How to Install Anything in Ubuntu (http://amitech.50webs.com/installing/index.php.html).

November 24th, 2008, 03:48 PM
unpack the zip

you will see a .bin file.

right click and select properties.

check the permissions tab, and check the allow executing this file checkbox.

its probably an installer.

good luck

November 24th, 2008, 04:05 PM
Being a glutton for punishment I downloaded this, extracted it, saw a .bin file, changed permissions ...and it doesn't work for me. According to http://cmap.ihmc.us/download/index.php?myPlat=Linux the system requirements list "RedHat 8.0 or higher version" Looks as though it might not work on Ubuntu?

November 24th, 2008, 04:12 PM
you could also try to find out where your local linux user group is and contact them :)

November 24th, 2008, 04:32 PM
Whether it works right or not i don't know, but to install extract the zip to your home dir.and make executable as described.

Then in terminal ./name.bin (change red to match extracted name.

Or to make life easier rename the extracted .bin to something easier like test1.bin. then you'd go in terminal ./test1.bin

Edit; Read below post first. (eldragon

I checked it out, installs fine, here's a more exact from the top with no renaming of the .bin (though it makes life easy

Right click on your zip file -> 'open with archive manager'

Click the extract button and in left side box (places) highlight your home folder (user name and click extract.

when it's done open a terminal (Applications -> accessories -> terminal

copy and paste this into the terminal and press enter on keyboard (will make the bin executable
Edit anything in red if different from the exact name of your .bin

chmod +x LinuxCmapTools_v4.18_06-09-08.bin

You should be returned to a prompt with no error message, if so then copy and paste this (again adjust red if needed


the installer should start

You should choose 'create a link', browse or set to desktop, see screen

good luck (I opened it after install - not a clue as to what it does

November 24th, 2008, 05:16 PM
exactly, after replying to this thread, i tried double clicking the .bin and it would not run.

opening the terminal and running with /path/to/filename.bin fixes it.

id advise you to run this program as root, so that it gets installed in a system directory and all links end up in the proper place.

November 25th, 2008, 07:54 AM
I DID IT!!!!WOW!! I did some actual coding.... after many many years (since the days of 'GW Basic')....

Honestly, I was about to give up on this linux thing and fall back on Windows.... But given the excellent guidance given by dedicated linux users like you guys..i will stick around...

Guys... THANKS A LOT!!!

Best Regards


November 25th, 2008, 08:13 AM
hey guys, now I have another problem......... installation all done but when I open the files open all blank screens!!! please help again!

November 25th, 2008, 08:24 AM
I have got Ubuntu 8.04 Hardy Heron

November 25th, 2008, 08:27 AM
may be I need to run it in root... how can i do that?

November 25th, 2008, 09:42 AM
Hopefully somebody can help you out ( that's what i meant by 'didn't have a clue what to do..

i uninstalled it and reinstalled as root - no change (grey windows
plus it was much harder to find (vs. /home

Maybe eldragon can help you there

Did find this (possible solution at bottom


Faq (probably not that helpful

November 25th, 2008, 01:16 PM
i dont know where your install resides, you will have to find that for yourself.

the solution proposed is the following:

rename the jre folder located in the install location IHMC_CmapTools/ to something else eg. mv jre jre.bak (you need to be on the IHMC_CmapTools/ directory for this to work)

which messes up with the local jre which should alredy be installed in your system.

a second less destructive solution proposed is to disable compiz temorarily when running the software.

just hit: alt-f2 and run "metacity --replace" without the quotes. this will kill all eyecandy..

to get eyecandy running again, (once you finnished using your software) hit: alt-f2 and type "compiz --replace"

November 26th, 2008, 12:44 AM
The compiz solution works quite well whether installed as root or to home dir.
The desktop link isn't created when installing as root, though easy to create one if you go that route.

November 26th, 2008, 12:18 PM

your solution worked!! Thanks again.


November 26th, 2008, 12:27 PM
by the way... what is 'eye candy'..... what happens when I run 'metacity replace' and back? besides getting me my software interface......??..and what is 'eyecandy'... sorry for the stupid questions as i am a complete novice...


November 26th, 2008, 05:29 PM
'eye candy' refers to 'desktop effects' or 'advanced desktop effects'
By default compiz is installed with some minimal effects.

To enable the advanced settings, effects you'd need to install compizconfig settings manager.

sudo apt-get install compizconfig-settings-manager

Then in System -> preferences you'll see in hardy - 'Advanced Desktop Effects Settings', in intrepid - ' CompizConfig Settings Manager'

The ability to use or to have effects work properly is dependent on your video adapter and video driver installed.

I find for my desktop the 'desktop cube' and 'rotate cube' very handy. You can have up to 16 cube sides and rotate them with the mouse scroll wheel. (having 4 sides is typical

There's a separate forum section just for 'effects'

screen shows some of the possible effects

November 26th, 2008, 06:34 PM
to be more specific, there are different ways to draw your screen.

when refering to eye candy, we usually mean the desktop is 3d redered and thus you get those nice effects when you minimize, maximize, and move windows. you can have more advanced effects that usuually clutter more than help.

the program in charge of doing this is called a windows manager.

metacity and compiz are both window managers, compiz being the one running all the fancy 3d stuff, while metacity is the default gnome windows manager.

when running metacity --replace, you are telling it to replace whatever windows manager there is running with metacity. (thats why there is a slight windows dissappearance).

some programs dont interact well with compiz, yours is one of them.