View Full Version : [all variants] ..MP-BIOS bug: 8254 timer not connected to IO-ACPI

November 24th, 2008, 12:56 AM
Hi to all.

I'm trying to install Ubuntu on a desktop computer but I get that error after selecting language and both choosing to run from LiveCD or installing it.

I've been first trying with Ubuntu 8.04 but the problem persist with Xubuntu 8.10

I've been trying using some kernel options at boot as noacpi, nolacpi, nosplash but had no luck.

I have AMIBIOS 1.21.12


November 24th, 2008, 08:35 AM
Try using

acpi_skip_timer_override as a boot option, if you are able to try disabling IO-ACPI in your bios as another possibility.

November 24th, 2008, 04:32 PM
The problem persist trying to install Xubuntu 8.10 alternate.

This is what I get having ACPI Aware O/S enabled, in both cases placing or not the acpi_skip_time_override kernel option

..MP-BIOS bug: 8254 timer not connected to IO-ACPI
ata1.00: revalidation failed (errno=-5)
ata1.00: revalidation failed (errno=-5)
ata1.01: failed to set xfermode (errmask=0x40)
ata1.01: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen

ata1.01: status: { DRDY }

switching to async

then black screen with command line cursor flashing but I'm unable to interact with the system...

On the other hand, what I get having ACPI Aware O/S disabled from BIOS is
ACPI: Unable to load the system description tables
followed by those lines above.
Actually I don't know if I stil get that switching to async In this case too, but for sure I get a black screen in this case too.
Also in this case I can get a Linux screen noticing that "The translation of the installer in incomplete for the selected language." (I choose Italian language)
but I'm unable to interact with the system throgh mouse or keyboard...

I've been trying to select installing it in English language and that mask doesn't appear any more. I get a [!!] Choose Language mask but again I'm unable to interact with the system.

November 25th, 2008, 01:48 AM
What are your system specs?

November 25th, 2008, 09:29 AM
It's not my own computer. I'm trying hard to give you the more infos as possible but I suppose I'm unable to retrieve motherboard type. Opening the case I can see some chips on the motherboard:

EOS Elitegroup
VIA VT8233 (with some infos more)
686 AMIBIOS 1989 (with some infos more)
ITE IT8705F (with some infos more)

Moreover, printed on the motherboard:

P4VXASD2 (which seems to be the mb model...)

November 25th, 2008, 12:08 PM
Try using
all_generic_ide or
irqpoll or both of them together as a boot option.

November 25th, 2008, 12:21 PM
Nothing changes.
I place boot options starting from <here> in the following line:

file=/cdrom/preseed/xubuntu.seed initrd=/install/initrd.gz <here> quiet --

So, for example, I tried:

file=/cdrom/preseed/xubuntu.seed initrd=/install/initrd.gz all_generic_ide quiet --

then I tried:

file=/cdrom/preseed/xubuntu.seed initrd=/install/initrd.gz irqpoll quiet --

and then:

file=/cdrom/preseed/xubuntu.seed initrd=/install/initrd.gz all_generic_ide irqpoll quiet --

But had no luck.

November 25th, 2008, 12:24 PM
When you boot the xubuntu cd at the main menu press F6 and at the end of the line add the boot option(s)

November 25th, 2008, 01:19 PM
I've been trying:

file=/cdrom/preseed/xubuntu.seed initrd=/install/initrd.gz quiet -- all_generic_ide

file=/cdrom/preseed/xubuntu.seed initrd=/install/initrd.gz quiet -- noacpi

file=/cdrom/preseed/xubuntu.seed initrd=/install/initrd.gz quiet -- noacpi nolacpi

file=/cdrom/preseed/xubuntu.seed initrd=/install/initrd.gz quiet -- irqpoll


well, I've been trying with all of the options named on this thread: writing them all alone, trying some (no all) combinations of them and finally writing all of them after that 'quiet -- ', but still no luck :-k

November 25th, 2008, 04:29 PM
The correct options are noapic and nolapic, but I wrote them uncorrectly (namely noacpi and nolacpi). Maybe my fault, maybe fault from some other forum... sorry anyway!

Reading on a couple of forums, I realized that the same problem could present even after installing Ubuntu. So I'll make some tests before tagging this thread as SOLVED!

Thanks for you time!