View Full Version : [gnome] nautilus not working, no desktop icons, cant open folders

November 23rd, 2008, 09:34 PM
hey, i'm pretty new to linux so i'm always trying new thing...

so... i tried to change my default file manager from nautilus to dolphin.
didn't like it... so removed it and wanted to go back to nautilus...
when i restarted, suddenly i dont have a responding desktop (no icons and right click doesn't work) + when i try to open Home or anything else i get an error messege:

Could not open location 'file:///home/ariel'
No application is registered as handling this file


p.s, sorry for my bad english...

November 23rd, 2008, 10:38 PM
If nautilus is still installed, right click on a folder using nautilus (Alt+F2 and enter the command nautilus if needed) and then put a check mark in "Open Folder"

November 24th, 2008, 05:48 AM
when i try to load nautilus i'm getting:

"The program 'nautilus' is currently not installed. You can install it by typing:
sudo apt-get install nautilus
bash: nautilus: command not found"

when i try to install:
using synaptic - nautilus is checked like its already installed
using terminal - "nautilus is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded."

November 24th, 2008, 12:55 PM
Try uninstalling nautilus and then reinstalling it using the terminal.

November 24th, 2008, 05:58 PM
i tried:

sudo apt-get remove nautilus
sudo apt-get autoremove

then i logged of and

sudo apt-get install nautilus

logged off again...

still doesn't work :'(
i'm about to go nuts!
i dont want to uninstall ubuntu because of such a silly thing ( like windows |-: )

November 24th, 2008, 06:03 PM
if it helps...


i can tell you i used this script to try making konqueror default

and i tried the script to restore nautilus and got:
You're missing a Computer .desktop backup file--nothing to restore
You're missing a Nautilus .desktop backup file--nothing to restore
You're missing a folder handler .desktop backup file--nothing to restore
You're missing a Home .desktop backup file--nothing to restore
You're missing a Network backup file--nothing to restore. If you had Thunar as your previous default file manager, this is normal.
Nautilus should now be your new default file manager in Gnome again


November 25th, 2008, 03:07 PM
someone please?