PDA

View Full Version : [ubuntu] Desktop effects could not be enabled. PLEASE HELP



philidox
November 21st, 2008, 02:40 AM
For the life of me I cannot enable desktop effects. I have done it before but this time I"m stuck. I have an Nvidia GeForce 7950GT as my video card. I installed the video drivers thru envyng and everytime I try to enable Desktop effects I get the message "Desktop effects could not be enabled" When I type in compiz into the command line I get this output

philidox@philidox-desktop:~$ compiz
Checking for Xgl: not present.
Detected PCI ID for VGA: 02:00.0 0300: 10de:0295 (rev a1) (prog-if 00 [VGA controller])
Checking for texture_from_pixmap: not present.
Trying again with indirect rendering:
Checking for texture_from_pixmap: not present.
aborting and using fallback: /usr/bin/metacity

And yes I do have xserver-xgl installed.

Here is my xorg.conf file:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder63) Wed Oct 1 15:09:35 PDT 2008

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
Option "HWCursor" "off"
Option "AddARGBGLXVisuals" "True"
SubSection "Display"
Depth 24
EndSubSection
Defaultdepth 24
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
Vendorname "NVIDIA Corporation"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "ServerLayout"
Identifier "Layout0"
screen 0 "Screen0" 0 0
Inputdevice "Keyboard0" "CoreKeyboard"
Inputdevice "Mouse0" "CorePointer"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "Monitor"
Identifier "Monitor0"
Vendorname "Unknown"
Modelname "Unknown"
Horizsync 30.0 - 110.0
Vertrefresh 50.0 - 150.0
Option "DPMS"
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Section "Files"
Rgbpath "/usr/X11R6/lib/X11/rgb"
EndSection

sauce345
November 21st, 2008, 04:30 AM
Have you tried installing the driver through the restricted drivers menu. I know i did that and restarted and things were perfect.

danf_1979
November 21st, 2008, 07:23 AM
Try $ sudo dpkg-reconfigure -phigh xserver-xorg, and then configure your driver to "nvidia". If it doesn't work, drop envy?

philidox
November 22nd, 2008, 06:56 PM
GOOD NEWS. I got it working!!! Here is what I did. Before I even logged in I hit "alt+f2" to get the cli. I unistalled envyng(sudo apt-get remove envyng-core envyng-gtk envgng-qt) . I also typed in that command that resets your xorg.conf file(sudo dpkg-reconfigure -phigh xserver-xorg). Then I downloaded the lastest Nvidia driver for linux directly from there website on another computer. Transfered it to my computer that I was fixing and installed it thru the cli. THERE IS ONLY GLITCH LEFT, my mouse is invisible. How do I fix that?!!! Thx for everything!