PDA

View Full Version : [ubuntu] How do I install IBM Infoprint 1312?



polemokles
November 19th, 2008, 04:20 PM
Hello everybody, first time poster.

I managed to install Ubuntu 8.10 at work. Everything works superbly - sound, resolution, internet, MS office document editing - to the point that nobody noticed I am not on Windows anymore. However, there is this little problem that's doing my head in.

Namely, I happen to be sharing an IBM Infoprint laser printer with another professor. No network, just a simple A/B serial Data Switch, so one would say it is a common serial plugged-in printer.

However, when going to System > Administration > Printing, when I click "New printer", Ubuntu is trying to detect new printers, but noting happens. Then I go the manual route, but the options it gives me are "JetDirect", "Windows Printer via SAMBA" and "Other" - all of them being specifically about network printers.

I tried using the troubleshooting wizard, however, at step 2, when I point out that the printer is directly plugged in, it says "Sorry, unable to help" or something similar.

Just out of curiosity, I followed every route that was offered to me, regardless of it being for network printers. Infoprint 1312 is not even listed among the makes and types offered during installation.

Out of despair, I got a .deb package for this printer from IBM's site, although it did not specifically say it was for Ubuntu. Double-click, everything's fine, installing drivers... Nope. Still no detection, and no Infoprint 1312 on any listing.

Is there anything I could do to make this printer work with Ubuntu, or am I fighting for a lost cause?

P.S. Sorry about this lengthy diatribe, but I tried to be as specific as I could.

polemokles
November 19th, 2008, 08:52 PM
Sorry to bump this, but... anybody?