View Full Version : [ubuntu] can't mount hard drive externally that was used internally by another laptop

November 19th, 2008, 01:31 AM
hi everyone,

i have a problem and require your assistance if you please.

first, i've recently converted to ubuntu/linux so please be gentle.

my problem is as follows:
i have an old compaq laptop that was running windows xp. about a year ago i gave up on it and bought a new one. the problem was that when i boot the laptop it would take about 25 minutes just to get to the main screen and if i click on a file or folder to access it it just takes about an hour (if i am lucky) to open it.

fast forward to now. i am using an acer 5920 laptop that only runs ubuntu 8.10 intrepid (after completley removing vista and reformatting). i wanted to access files from the old compaq laptop, so i took the hard disk out (which is an old toshiba 10gb hard disk) and inserted it in a 2.5" hard disk enclosure that i bought just for doing this. (by the way, the enclosure does not have its own power unit, it uses the usb connection for that)

the theory is to try to access the hard disk as an external hard disk.

when i connect the 'now converted into an external' hard drive to my laptop nothing happens. i also can not mount the drive. if i go to 'computer' i see: 1- file system 2- cd-rom 3- usb drive.nothing else is connected to the computer except this hard drive so it must be showing as labeled 'usb drive'. if i double click to mount i get the 'can't mount' error. if i right click and select 'mount volume' from the context menu nothing happens.

here is a screen shot befor i inserted the external hard drive:
(screenshot 1) (at the bottom of the post)

and this is a screen shot after i attached the external hard drive:
(screenshot 2) (at the bottom of the post)

i get the following when i run fdisk -l

luay@luay-laptop:~$ sudo fdisk -l
[sudo] password for luay:

Disk /dev/sda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x3ba2676f

Device Boot Start End Blocks Id System
/dev/sda1 * 1 3039 24410736 83 Linux
/dev/sda2 3040 14593 92807505 5 Extended
/dev/sda5 3040 3647 4883728+ 82 Linux swap / Solaris
/dev/sda6 3648 14593 87923713+ 83 Linux

i get exactly the same output if the external hard disk is not connected. so i guess fdisk -l can't 'see' the external hard disk.

please also note tht when i formatted the currently being used acer i only created sda1, sda5 and sda6. i don't know where the sda2 (extended) partition came from unless it is automatically created by ubuntu. i am guessing since i get the same output for 'fdisk -l' then this sda2 has nothing to do with the external hard disk.

my /etc/fstab looks as follows:

# /etc/fstab: static file system information.
# -- This file has been automaticly generated by ntfs-config --
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
# Entry for /dev/sda1 :
UUID=6c52ecf3-7178-42a1-94b9-e54ee4ba5662 / ext3 relatime,errors=remount-ro 0 1
# Entry for /dev/sda6 :
UUID=5e28bc86-e0f1-4ded-8207-26e14d642602 /home ext3 relatime 0 2
# Entry for /dev/sda5 :
UUID=91ecd7fb-3c52-4c8c-ae68-ffc7bec4e22d none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0

i think nautilus recognizes the hard drive as 'usb drive' but can't mount it or open it or anything. and fdisk just can't 'see' the hard drive.

i tried the following to no avail.

1- inserted the '#' sign at the beginning of the last line in fstab. it didn't work.

2- created a mount directory to try mount manually. so i did the following

sudo mkdir /media/external

then executed the following command:

sudo mount -t ntfs-3g /dev/sda2 /media/external

because i thought maybe, just maybe sda2 is the external hard drive but i got the following:

luay@luay-laptop:~$ sudo mount -t ntfs-3g /dev/sda2 /media/external
[sudo] password for luay:
NTFS signature is missing.
Failed to mount '/dev/sda2': Invalid argument
The device '/dev/sda2' doesn't have a valid NTFS.
Maybe you selected the wrong device? Or the whole disk instead of a
partition (e.g. /dev/hda, not /dev/hda1)? Or the other way around?

3- i tried

sudo fdisk -l
sudo mount

and i got the following:

luay@luay-laptop:~$ sudo mount
/dev/sda1 on / type ext3 (rw,relatime,errors=remount-ro)
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
/proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
varrun on /var/run type tmpfs (rw,nosuid,mode=0755)
varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
lrm on /lib/modules/2.6.27-8-generic/volatile type tmpfs (rw,mode=755)
/dev/sda6 on /home type ext3 (rw,relatime)
securityfs on /sys/kernel/security type securityfs (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/luay/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=luay)

i hope i was able to explain the problem clearly. if you need me to run any additional commands i'll be glad to do so. all i need to do is access this old hard drive so i can copy the files from it to the new laptop.

many thanks for reading this and for your help.