View Full Version : [ubuntu] MP3 Player Won't Mount When Plugged In

November 17th, 2008, 09:00 PM
Hey all...

I've been using Ubuntu for about a year now. I have a HP Pavilion ze5170 laptop running Gutsy Gibbon.

Up until about a month ago, my mp3 player (a Sandisk Sansa e280 in MSC mode) worked flawlessly - I plugged it in and it automatically showed up as a removable drive (two removable drives, technically - one for the internal memory and one for the memory card). However, at some point the memory card was accidentally made read-only, a problem which took me hours to get to the root of, and in the process I messed something up badly enough that it wouldn't mount at all. Then, after a couple more hours, I successfully mounted it manually, and naively hoped that it would somehow "save" those settings and return to automatically mounting whenever plugged in. No dice. How can I make it mount automatically again?


- Ethan

November 18th, 2008, 08:07 PM
...any takers on this one? Any at all?

November 18th, 2008, 09:27 PM
Your mp3 player works perfectly in hardy. But a upgrade would probably cause more problems than it would solve. But I guess we could start by asking is automount completely broken? Do other usb devices work? How about cd's?

That being said why don't you post this (or have a mod move it to).

Beginner's Guide to a Sansa e200 MP3 Player

December 5th, 2008, 05:19 PM
My E260 stopped mounting (it always went to the "refresh database" screen when I plugged it in) when I added a MicroSD card. Finally I tried mounting the E260 _without_ the card, and it worked. I plugged in the MicroSD card into the mounted E260, and the card mounted successfully.