View Full Version : [ubuntu] 8.10 Upgrade - Dell Inspiron - Keyboard locks up on using func keys

November 16th, 2008, 08:40 PM
Hi All,

I've noticed a bug on my Dell inspiron 1300 following the upgrade to 8.10. If I use the Fn key to, for example, control the screen brightness then I lose the ability to use my keyboard, left mouse key etc, I can still use the cursor but can't really do a lot with it, it pretty much locks up and I have to restart the laptop to re-use.

Can anyone help shed any light on this ?


November 20th, 2008, 08:51 PM

Unashamed Bump...anyone shed any light on this ?


November 26th, 2008, 03:48 PM
Same problem here. On my Dell Precision M65.
I cannot write anything.
I can reset the X layer using ctrl-alt-backspace.
I can continue to control the brightness of the screen.

December 5th, 2008, 12:08 AM
Same problem here, on a Inspiron 5100. I have to switch to a different virtual terminal and back to fix it (with Ctrl-alt-1 and Ctrl-alt-7).

December 5th, 2008, 03:25 PM
What are your power management settings,
On AC power: display; Display brightness 100%
UN check dim display when idle.

I have inspiron 6400 and brightness control now works fine.


January 7th, 2009, 12:46 AM
I have a Dell Inspiron 1545 laptop and am also getting the same issue. The keys still seem to work, but after pressing them it seems to break the desktop. I have to do a Ctrl + Alt + Backspace to recover.

These keys were working fine for me under 8.04

January 17th, 2009, 05:09 PM
What are your power management settings,
On AC power: display; Display brightness 100%
UN check dim display when idle.

Same problem here on a Dell 1545. The display brightness changes. The screen icon (little sun) won't go away, keyboard doesn't work and mouse buttons do not work. Restarting X will correct problem. The volume buttons work fine. Tried the above suggestion and problem persists.

January 25th, 2009, 04:32 PM
The same problem over here too on my inspiron 9300.
Keyboard locks down entirely when I use function key (except for Ctrl-Alt-BSpace)

April 13th, 2009, 12:46 AM
I'm running 8.10 inside Windows on my Inspiron 9300 and have exactly the same problem. It seems like this is a documented bug with the kernel; see
I haven't been able to find a fix. Anybody know what's going on with this?

April 14th, 2009, 03:32 PM
This problem has been going on since Intrepid came out. It started working on my laptop a couple of weeks ago, but now it is broken again. There was a work around of using Crtl+Alt+F1 as a work around for the brightness issues, However I just tried it and that is now broken too, suggesting it's a different bug.

April 14th, 2009, 03:45 PM
Interestingly dropping into the shell seems to fix the issue. Not a pretty way of changing your screen brightness though.

November 4th, 2009, 05:28 PM
Im having the same problem on my Samsung R560 ever since I installed Karmic 9.10. Jaunty 9.04 did not have this problem.