PDA

View Full Version : [ubuntu] [SOLVED] Screen Resolution (800x600)



Pezhead
November 16th, 2008, 05:29 AM
I hate that my first post is this but what can you do? Anyways, I have seen a lot of threads on google about this but none for intrepid. I switched from Hardy Kubuntu to Intrepid Kubuntu and had no problems. Well my Kubuntu crashed and I had to re-format my computer. Long story short, I switched over to Ubuntu for the time being but my resolution is stuck at 800x600. Now I know you can edit xorg.conf, however, I am not sure what to type in there and I don't want to crash my comp again. I also tried sudo dpkg-reconfigure xserver-xorg, however, it mentions nothing about the monitor in there. Any help would be appreciated.

SunnyRabbiera
November 16th, 2008, 05:31 AM
yeh there not being a proper display editor in ibex is what keeps me away from it, manually editing xorg should not be necessary and forced.
I think it was a stupid move to remove the tools that made editing xorg easier.

alwayshere
November 16th, 2008, 05:34 AM
what graphics card are you using

if you dont know go to terminal and put

sudo su

then

lshw

and post the result

Pezhead
November 16th, 2008, 05:44 AM
I am using NVIDIA GEFORCE 6150 LE. That is initially what caused Kubuntu to crash. I installed the proprietary drivers and Kubuntu crashed.

alwayshere
November 16th, 2008, 05:51 AM
looks like this might sort ya out

http://sudan.ubuntuforums.com/showthread.php?t=970237

alwayshere
November 16th, 2008, 05:54 AM
also note that nvidia cards dont like the ubuntu staard theme "human"
so change theme to clearlooks or somthing otherwise you you may have troubles

Pezhead
November 16th, 2008, 05:55 AM
Thanks. If I get the drivers to work will that fix the screen resolution?

Pezhead
November 16th, 2008, 06:17 AM
I updated my drivers to .96 and they seem to work with intrepid. However, my resolution is still stuck at 800x600.

alwayshere
November 16th, 2008, 06:19 AM
on a mates pc which has a nvidia card a short time ago he was running 8.04 and had the same resolution trouble so i used this command

gksudo displayconfig-gtk

to bring up a grapical menu to cange the driver mode from nv to nvida......
which fix the trouble
but i think that command might no work in 8.10 .
maybe try it and see

Pezhead
November 16th, 2008, 06:21 AM
on a mates pc which has a nvidia card a short time ago he was running 8.04 and had the same resolution trouble so i used this command

gksudo displayconfig-gtk

to bring up a grapical menu to cange the driver mode from nv to nvida......
which fix the trouble
but i think that command might no work in 8.10 .
maybe try it and see

I had to do the same thing with Hardy. However, with IBEX they removed that command. I know you can still update the xorg.conf but I am not sure of the proper format I need to use.

alwayshere
November 16th, 2008, 06:29 AM
sudo apt-get install nvidia-config

The NVIDIA X Configuration Tool
nvidia-xconfig: A tool for manipulating X config files,
specifically for use by the systems with
the NVIDIA Linux graphics driver.

might help sorry i can only offer ideas in which i would try but as im running a ati card at the mo i can run through it myself

Pezhead
November 16th, 2008, 06:36 AM
Hmmm interesting. This is what I got:

Using X configuration file: "/etc/X11/xorg.conf".

VALIDATION ERROR: Data incomplete in file /etc/X11/xorg.conf.
Device section "Configured Video Device" must have a Driver line.

alwayshere
November 16th, 2008, 07:03 AM
this forum looks good got a few stickies

http://www.nvnews.net/vbulletin/forumdisplay.php?f=14

alienexplorers
November 16th, 2008, 07:16 AM
Is your xorg.conf setup like this. If not, give it a try. It solved my resolution problems:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildmeister@builder57) Mon Oct 27 14:38:08 PST 2008

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "freetype"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "ViewSonic"
ModelName "ViewSonic VA703 SERIES"
HorizSync 30.0 - 82.0
VertRefresh 50.0 - 85.0
ModeLine "1280x1024_60.00" 108.9 1280 1360 1496 1712 1024 1025 1028 1060 -hsync +vsync
Option "DPMS"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce FX 5200"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "NoLogo" "True"
Option "RenderAccel" "True"
Option "AllowIndirectPixmaps" "True"
Option "AddARGBGLXVisuals" "True"
Option "AllowGLXWithComposite" "True"
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "enabled"
EndSection

Pezhead
November 16th, 2008, 07:21 AM
sudo apt-get install nvidia-config

The NVIDIA X Configuration Tool
nvidia-xconfig: A tool for manipulating X config files,
specifically for use by the systems with
the NVIDIA Linux graphics driver.

might help sorry i can only offer ideas in which i would try but as im running a ati card at the mo i can run through it myself

Once again NVIDIA drivers could not be loaded and my computer crashed so had to do fresh install. I will try to edit my xorg.conf with the post above and see if that works.

Pezhead
November 16th, 2008, 12:45 PM
Ok so this is how I fixed the problem. I hope this helps anybody else who has this issue. Hopefully there is an easier way out there.

1). I had to reload Hardy Heron onto my computer.
2). From there I ran gksudo displayconfig-gtk
3). I changed my monitor and graphics information to the correct settings.
4). After that I ran sudo /etc/X11/xorg.conf to verify the information updated correctly.
5). Once I did all of that I ran updates to make sure Hardy was updated and then updated my computer once more to IBEX and it was fixed.

Now this is probably the most time consuming method there is but it is the only thing I could find that would work.