PDA

View Full Version : [ubuntu] i810 driver in Intrepid



metallicamike
November 15th, 2008, 07:58 PM
i have an old dell and with it an integrated intel graphics card apparently i have mesa drivers running on it and those suck. So the guy that said that recommended i get the i810 driver. How do i do that in intrepid? where do i install it? i tried the hardware devices menu but nothing comes up! what can i do to get it??

ugm6hr
November 15th, 2008, 08:16 PM
I use the i810 driver on Hardy.

Looking at this: http://packages.ubuntu.com/intrepid/xserver-xorg-video-i810
It looks like this is no longer required.

No harm in giving it a try: apt:xserver-xorg-video-i810

metallicamike
November 15th, 2008, 08:48 PM
it says its already installed....i just need to know how to make it wat my card uses

ugm6hr
November 15th, 2008, 09:57 PM
Post the output from these:

cat /etc/X11/xorg.conf
lshw -class display

Not sure how Intrepid behaves - so I am wary about offering much advice re: changes, but it is useful for others to know what's going on.

From memory (my Intel laptop has since been donated to my mum), I just changed xorg to have "i810" in the display driver, but this was in Gutsy / Hardy.

metallicamike
November 15th, 2008, 10:35 PM
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection
michael@MikesAwesomePC:~$ lshw -class display

here ya go

metallicamike
November 15th, 2008, 10:36 PM
*-display UNCLAIMED
description: VGA compatible controller
product: 82865G Integrated Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 02
width: 32 bits
clock: 33MHz
capabilities: pm bus_master cap_list
configuration: latency=0


here is the other one too:lolflag:

mbturner
November 16th, 2008, 05:06 AM
I am having driver issues in Intrepid. My xorg.conf file doesn't have a Driver entry. Here it is:


Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection


That's seriously it. Really small, and there is no place to put my driver.

Whenever I change it to this:
Section "Device"
Identifier "Configured Video Device"
Driver "i810"

it just wont boot anymore. Any help?

metallicamike
November 16th, 2008, 05:25 PM
thats exactly wat mine does, only mine boots cuz i dont know how to put in drivers

metallicamike
December 22nd, 2008, 07:01 PM
bump

igknighted
December 22nd, 2008, 08:00 PM
I am having driver issues in Intrepid. My xorg.conf file doesn't have a Driver entry. Here it is:


Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection


That's seriously it. Really small, and there is no place to put my driver.

Whenever I change it to this:
Section "Device"
Identifier "Configured Video Device"
Driver "i810"

it just wont boot anymore. Any help?

Try Driver "intel" instead of Driver "i810". I believe the i810 driver has been deprecated, and according to http://intellinuxgraphics.org/documentation.html your card is supported by the intel driver.

metallicamike
December 22nd, 2008, 11:41 PM
so how do i get rid of the i810 and make sure that it is using the intel driver when i get rid of the i810?

igknighted
December 22nd, 2008, 11:58 PM
so how do i get rid of the i810 and make sure that it is using the intel driver when i get rid of the i810?

Just change it in xorg.conf. Right where you wrote "i810", write "intel" instead.

metallicamike
December 23rd, 2008, 12:08 AM
where is xorg.conf? i knew at some point, but i cant remember. and do i have the permissions to edit it?

igknighted
December 23rd, 2008, 12:15 AM
where is xorg.conf? i knew at some point, but i cant remember. and do i have the permissions to edit it?

Just as you did above in the thread, run:

sudo nano /etc/X11/xorg.conf
This will start an editor in the terminal. Find the section "Device" and change the line Driver "i810" to Driver "intel" (Going off what you posted above, it is theoretically possible that it looks different now. If there is no Driver line, add it as I indicated above.

If you still don't know, post the contents of that file (/etc/X11/xorg.conf) and I will change the line and highlight it red so you know what I mean.

metallicamike
December 23rd, 2008, 12:22 AM
like this?
Section "Device"
Identifier "Configured Video Device"
Driver "intel"
Option "UseFBDev" "true"
EndSection

igknighted
December 23rd, 2008, 12:25 AM
Yes, exactly.

But comment out that usefbdev line (place a # in front of the line, Ubuntu will then ignore it).

metallicamike
December 23rd, 2008, 12:29 AM
ok, now how do i make it save?

igknighted
December 23rd, 2008, 12:30 AM
ok, now how do i make it save?

<ctrl> + o, then <ctrl> + x to quit.

Am-Achraf
December 23rd, 2008, 12:34 AM
ubuntu 8:10: problem with sound in Skype

Hello,

I've installed Intrepid Ibex and it's working fine except with Skype. I have no problem with any other application concerning sound but with Skype I get the following message: "Problem with the sound pilot" (or something to that effect -I'm translating form French: "Problème avec le péripherique de capture audio"). If I make a test sound, I hear the sound. But when I try making a call, it rings once, then stops and the message above appears.

Thanks,

metallicamike
December 23rd, 2008, 12:37 AM
you r in the wrong place pal lol, this is for video but go to system>preferences>sound and make sure everything is set to ALSA, that is the best I can give you. But im sure some one in here knows.

metallicamike
December 23rd, 2008, 12:38 AM
to igknighted, how do i know that it is working?

igknighted
December 23rd, 2008, 12:41 AM
ubuntu 8:10: problem with sound in Skype

Hello,

I've installed Intrepid Ibex and it's working fine except with Skype. I have no problem with any other application concerning sound but with Skype I get the following message: "Problem with the sound pilot" (or something to that effect -I'm translating form French: "Problème avec le péripherique de capture audio"). If I make a test sound, I hear the sound. But when I try making a call, it rings once, then stops and the message above appears.

I'm not the only one -I've seen this question posted tens of times- but nobody is getting an answer. I need to make a call tomorrow and I'd hate to have to go to the trouble of installing 8:04 again. Besides, I threw the CD away!

Thanks,

That has nothing to do with this thread, you should start a new thread in order to get the proper support.

igknighted
December 23rd, 2008, 12:42 AM
to igknighted, how do i know that it is working?

You will need to reboot, and if the graphics load properly, it worked. If it tries to go to failsafe mode, there was a problem.

metallicamike
December 23rd, 2008, 12:50 AM
ok, what if everything is exactly the same but it isnt in failsafe mode?

igknighted
December 23rd, 2008, 12:52 AM
ok, what if everything is exactly the same but it isnt in failsafe mode?

Hmm, well the intel driver is being used... what issues are you having?

metallicamike
December 23rd, 2008, 01:06 AM
streaming video, see my other threads

igknighted
December 23rd, 2008, 01:11 AM
streaming video, see my other threads

There are some driver options you can try. Also, you might want to disable desktop effects, as these often can interfere with graphics playback.

metallicamike
December 23rd, 2008, 01:13 AM
what do you mean by driver options?

igknighted
December 23rd, 2008, 01:16 AM
what do you mean by driver options?

I'm trying to find a guide... basically lines you can add to xorg.conf to turn on or off different features of the driver.

metallicamike
December 23rd, 2008, 01:23 AM
that sounds neat

igknighted
December 23rd, 2008, 01:31 AM
Try adding this line right under the last one you added:


Option "XvMC" "true"

EDIT: Streaming video... what format? If you download the video, does it still have issues? Do you have ipv6 enabled? Sometimes that can cause issues.

metallicamike
December 23rd, 2008, 01:37 AM
youtube works perfect, but everything else kinda sucks. and if it is downloaded it works fine, and how do i look at ipv6?

metallicamike
December 23rd, 2008, 01:48 AM
the effects seem to work alot better but streaming video still is really choppy, but not quite as bad

metallicamike
December 23rd, 2008, 02:09 AM
bump

metallicamike
December 23rd, 2008, 02:35 AM
Bump!!!

metallicamike
January 11th, 2009, 11:47 PM
i still need to know how to look at iPv6 people

ugm6hr
January 11th, 2009, 11:49 PM
i still need to know how to look at iPv6 people

Sorry - that doesn't make any sense.

ipv6 has nothing to do with graphics drivers. It has to do with DNS resolution (or something like that).

metallicamike
January 11th, 2009, 11:51 PM
well how do i make sure that it is enabled? like igknighted said

igknighted
January 11th, 2009, 11:54 PM
well how do i make sure that it is enabled? like igknighted said

You should start a new thread on this, as it is a different topic now.