View Full Version : [all variants] how do I set up an ssh server?

November 14th, 2008, 10:12 PM
it shows in synaptics that openssh-server is already installed...I dont understand. running 8.10

November 14th, 2008, 10:13 PM
It's installed, but not necessarily running

In order to start it run:

sudo /etc/init.d/sshd start

Then you should be able to connect to that computer using SSH.

November 14th, 2008, 10:14 PM
Sounds like you are already running it.

To verify that the ssh-server daemon is running:

ps aux | grep sshd

November 14th, 2008, 10:14 PM
okay if openssh server is installed do the following to check if it is running.

sudo aptitude install nmap
nmap -A localhost -p 22

If you see the OpenSSH running all is well, you can connect to it using putty or ssh in terminal.

To modify the configuration you need to edit "/etc/ssh/sshd_config". Hope thats what you're after.

November 14th, 2008, 10:17 PM
Here is a link to basic SSH from ubuntu documentation:
SSHHowto (https://help.ubuntu.com/community/SSHHowto)

And Advanced:
AdvancedOpenSSH (https://help.ubuntu.com/community/AdvancedOpenSSH)

November 14th, 2008, 10:18 PM
I have run BOTH commands, and this is the respective output:

syn3rgy@zer0cool:~$ ps aux | grep sshd
root 18540 0.0 0.0 5392 1036 ? Ss 15:10 0:00 /usr/sbin/sshd
syn3rgy 18737 0.0 0.0 3236 804 pts/0 S+ 15:16 0:00 grep sshd
syn3rgy@zer0cool:~$ sudo /etc/init.d/sshd start
sudo: /etc/init.d/sshd: command not found

so that means its running...but I can't configure it?? o.O

when I try to ssh to my ip, it immediately says the connection is refused

November 14th, 2008, 10:20 PM
nvm. I put two and two together...now it works. Thank you! *solved* and *thanks all around*

November 14th, 2008, 10:22 PM
Ok so the daemon isrunning. Are you trying external ip or network ip?

Does "ssh localhost" work or does that fail too. If it fails it'd be useful to see the "/etc/ssh/sshd_config" file.

PS: the command to start the server is

/etc/init.d/ssh start

November 18th, 2008, 08:26 PM
Thanks for the correction. I guess I've become something of a tab-completion addict and can't remember actual command names (particularly from a windows machine).