View Full Version : [ubuntu] Automatic login doesn't work in 8.10, fine in 8.04

November 14th, 2008, 05:30 AM
I have Login > Security > Enable Automatic Login > my profile. However this doesn't work in 8.10, I still get prompted for my user / password upon bootup.

November 14th, 2008, 03:19 PM
Did you select the proper user to logon as and everything?

November 14th, 2008, 05:07 PM
Yup, the odd thing is it works about half the time without changing any settings . . .

December 7th, 2008, 10:26 PM
Say Ancient,

Did you ever solve this? I have the same problem and was hoping for an easy fix :)

December 8th, 2008, 04:13 AM
Unfortunately not. It happens sporadically and I've just learned to deal with it. :(

December 8th, 2008, 02:15 PM
I did some searching but I'm not smart enuf to know what I read. This has some entertaining, but not very informative, comments.

This one also mentioned keyring with an alleged work-around but now it doesn't load so I can read it again. I've been trying for a couple of hours but it just times out.

In my case it doesn't seem to work but I suspect it does. That is, I think it logs me into gdm but another app (network manager?) doesn't want to play.

I have disabled remote login ability to the best of my knowledge and physical security of the machine is not an issue so I just wanted to make life a little easier. Alas, that is not in the unix playbook.

December 8th, 2008, 05:29 PM
I got thru to the second site and it did suggest deleting the default keyring and entering a blank one.

I could not find a gui for this so I renamed the login.keyring file at ~/.gnome2/keyrings. No change - the file was just recreated.

I have read in the past how text config files were so much more flexible than Win but this issue doesn't support that. It's just a different group of people pulling the strings.

December 10th, 2008, 11:09 PM
FYI, I have this problem as well... Automatic login works sometimes, but not all the time... I don't have time to dig into this myself now, I was kinda hoping to not have this kind of problems with Ubuntu now... I recently made my first serious install of Linux in many years...

December 10th, 2008, 11:15 PM

I hope you don't use Skype.