PDA

View Full Version : [ubuntu] microphone doesnt work, recording or Skype



jmcgovern
November 14th, 2008, 02:14 AM
hi,

Been having some problems with sound. Specifically, am unable to use the microphone in my Altec Lansing headset. I can hear just fine out of the earpieces but the microphone will not record sound in any way. I also cannot be heard in Skype either.

Here are my system specs.

http://www.shopping.hp.com/webapp/shopping/computer_can_series.do?storeName=computer_store&category=desktops&a1=Brand&v1=HP+Pavilion+Slimline&series_name=s3600t_series

starcannon
November 14th, 2008, 02:24 AM
In skype, on every one of my computers, I have to:


Open Options Menu
Open Sound Devices sub-menu
Change each drop down from Default device(defualt) to the first item under it on the list, usually device 0; the format is something like"SOMEDEVICE Some-chipset (hw:Some-chipset,0)
Press "Test Sound" if that works then press Test Call, if you can hear yourself in the test call play back, your set.

GL and keep it fun.

jmcgovern
November 14th, 2008, 02:33 AM
I tried every single option there and none of them play back, some of them wont even complete the call. Also just using SOund recorder doesnt work.

GoManVanGogh
November 14th, 2008, 03:18 AM
I'm having a similar problem. Was fine under 8.04. Sound works, but I can't record or use the mike. Skype immediatly goes to PROBLEM WITH AUDIO PLAYBACK as soon as I hit a call button.

More like no microphone is present.

jmcgovern
November 14th, 2008, 02:49 PM
I can get Skype to make a test call with some settings but it never plays back my voice. Audio recording just doesnt play back, period.

starcannon
November 14th, 2008, 05:13 PM
On a few systems I've dealt with I've had to go into System>Preferences>Sound and set everything to Alsa, and choose my sound device from the bottom most drop down menu.

Outside of that you may have to go as far as uninstalling Pulse Audio; I've never had to do that, but I've read that some people have.

GL Keep us posted on how your coming along.

GoManVanGogh
November 14th, 2008, 05:43 PM
Are we all using GNOME? In another thread on the forum, I found that some people had to us the terminal to open the Gnome sound preferences panel. I did that, and found that the microphone had been turned off.

I'm not jumping for joy, because turning it back on didn't make anything work. The sound panel from the menu items is not the same as the gnome sound preferences panel. I think that may control the other.

jmcgovern
November 14th, 2008, 06:45 PM
Are we all using GNOME? In another thread on the forum, I found that some people had to us the terminal to open the Gnome sound preferences panel. I did that, and found that the microphone had been turned off.

I'm not jumping for joy, because turning it back on didn't make anything work. The sound panel from the menu items is not the same as the gnome sound preferences panel. I think that may control the other.

GMVG,

I am indeed using GNOME. Didn't know about the separate control panel. what terminal command do i use to access that? maybe that will work. It'll at least be another place that the microphone is turned on.....

GoManVanGogh
November 17th, 2008, 05:48 AM
GMVG,

I am indeed using GNOME. Didn't know about the separate control panel. what terminal command do i use to access that? maybe that will work. It'll at least be another place that the microphone is turned on.....

Execute the following command: gnome-volume-control

I've made some progress - have been able to get the sound recorder to recognize the microphone. So it's not totally broken. I found the RTFM principle (Read the Manual, Sir!) to be helpful. www.gnome.org has a good set of docs. http://library.gnome.org/users/gnome-volume-control/stable/gnome-volume-control-getting-started.html.en is about the volume control.

I note that the Ubuntu 8.10 upgrade seems to have the very latest GNOME desktop - the release notes say that it has "improvements" in sound and audio for internet conferencing.

Best of luck! Now to see if Skype works.

GoManVanGogh
November 17th, 2008, 06:03 AM
More Tweaks needed in Skype - Success

OK, I've now got Skype working. There's nothing intuitive.

Go to Skype Options. It will let you make test sounds. You will see a drop down for sound in and out. From other reading it was suggested that I try setting it to PULSE for both. That did not work, but using PULSE on Sound Out got me some headway with the test call.

I went down my option list, and the setting that worked for me (an older Intel motherboard for sound, yours will likely be different) was Intel 82801 DB-ICH4 (hw:I8201DBICH4,0). Durned if I know what that means, but I have been able to not only hear the nice British lady's voice, but my own voice back at proper levels.

YMMV, of course :guitar:

Pat T
June 22nd, 2009, 04:53 PM
I have been trying to get the microphone to work. I even bought a new headset! But still no luck. I am on jaunty jackaloupe. I have tried all the suggestions already in this forum.