View Full Version : [ubuntu] Upgrade 8.04-> 8.10 says "0 packages to install"

November 12th, 2008, 08:28 PM
I tried to upgrade Ubuntu 8.04 to 8.10 (after having installed all updates for 8.04, and rebooted twice).
What happens is:

I start the update manager;
I click on the "upgrade" button;
some kind of release note is shown;
I click on the "upgrade" button;
two files are downloaded (called the upgrade program);
I am asked for my password;
nothing more, no errors, no windows.

I then tried it using the command line:

run sudo aptitude update;
run sudo aptitude dist-upgrade;
aptitude says 0 packages have to be removed, update or installed.

I tried the same after disabling third party repositories, but that didn't change anything.

What's wrong here?

November 12th, 2008, 08:39 PM
Look at Software Source in the System menu. Go to the updates tab and in a list box near the bottom you may find it shows to only do upgrades to LTS releases. If so, you can change that to Normal releases and then try the update manager again.

November 12th, 2008, 09:33 PM
I already did that, otherwise the update manager would not have shown the "upgrade" button.