View Full Version : [ubuntu] GD is not activated or doesnt work

November 10th, 2008, 10:03 PM

I have a few weeks old ubuntu server installed with LAMP. For some reason Joomla reports GD not to be installed. Also, http://www.zulan.se/phpinfo.php says it's not there. I have installed it using apt-get install php5-gd and it finishes successfully but still, Joomla reports the same problem and can't manipulate the images. I'm fairly new to linux so a detailed answer is much appreciated!

php -m says gd is there


November 22nd, 2008, 01:18 AM
Same issue here with Ubuntu Server 8.04.1 and PHP5. The following worked for me. It will install a GD pre-compiled working version. It is a complete bundled (forked) GD libraries:

If not already done removing your current GD package and its configurations.

sudo apt-get --purge remove

Adding 2 lines to your file /etc/apt/sources.lst

deb http://packages.dotdeb.org stable all
deb-src http://packages.dotdeb.org stable all

Updating your current apt-get list
apt-get update
Installing working GD package.

apt-get install php5-gdIt will complain about non-authenticated sources, just ignore, it will also update some additional php libs.

When prompt select keep_current modified php.ini

Restarting Apache

/etc/init.d/apache2 restartEnjoy

Source: http://drupal.org/node/134331#comment-983886

February 6th, 2009, 11:06 PM
awesome. after sever different solutions, yours is the only one that worked. thanks!