PDA

View Full Version : [SOLVED] [GCC Problem] Localized output - How to get rid of it :) ?



dempl_dempl
November 10th, 2008, 01:46 PM
Hi folks,

To show what I mean , here are couple of simple examples:



dule@dule-laptop:~$ gcc --version
gcc (ГЦЦ) 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)
Copyright 2006 Free Software Foundation, Inc.
Ово је слободан софтвер; погледајте изворе за услове копирања. Нема БИЛО КАКВЕ
ГАРАНЦИЈЕ; чак ни за КОМЕРЦИЈАЛНУ ВРЕДНОСТ или ИСПУЊАВАЊЕ ОДРЕЂЕНЕ ПОТРЕБЕ.




dule@dule-laptop:~$ gcc
gcc: нема улазних датотека


Ok, I admit , it looked cool couple of months ago . I still like GCC showing errors on Serbian. Although, translations are sometimes funny :)

The problem is, however, that now I'm having problem with my editor ( SlickEdit ) . It can't parse the GCC's build output right ( obviously some Unicode issue with SlickEdit ) . The thing is,

The thing is, I really forgot how on Earth did I installed that :) .

I would be grateful if someone could tell me any way to display error messages in English .

I will even remove Serbian completely, if necessary , but , it would be a lot better if gcc had something like '--force-us-english-output' option :) .


What I've tried so far :

Set English to be default KDE's language
Remove localization package for GCC


And, I almost forgot , Ubuntu is 7.10 , GCC is 4.1 .


Thanks in advance,
Eh, Me :)

geirha
November 10th, 2008, 01:59 PM
LANG= gcc --version
# Or a specific language
LANG=en_US.UTF8 gcc --version
# You can also export it to change translations for
# all commands run in that terminal
export LANG=en_US.UTF8
gcc --version
# And this lists all locales you have available.
# LANG= is the same as LANG=C
locale -a

dempl_dempl
November 10th, 2008, 06:02 PM
Thanks mate, problem solved :)