PDA

View Full Version : [all variants] No sound Ubuntu Intrepid ALC880



foxh8er
November 9th, 2008, 05:18 PM
I am just beginning with ubuntu- I installed my first full copy today.
A major problem I am having is that there is absolutely no sound coming out of the headphone jack at all- it does not work with speakers, headphones, ect.
I am running a desktop without internal speakers, and I cannot find anything in the forums with a situation similar to mine.

Thanks in advance.

P.S- I am running the ALC880 controller, which worked perfectly with windows.

roger_1960
November 9th, 2008, 05:28 PM
Hi

Go to a terminal

applications-accesories-terminal

then type:

alsamixer

In the GUI which appears, check that master vol and others are not set to zero. Use the left/right arrows to move around and set volumes. Sometimes new installs set everything to silent.

WelshChris
November 9th, 2008, 06:06 PM
Sometimes you need to select the card that alsamixer is working with.
So try
alsamixer -c0
or alsamixer -c1

73ckn797
November 9th, 2008, 06:10 PM
Double click on the speaker icon and set volume levels. Enable all options for settings in preferences once you are in volume control window. This accomplishes the same as using terminal.

foxh8er
November 11th, 2008, 02:56 AM
Thanks for the suggestion, but I have done that already with no avail.

I am still confused, however, on the devices on that panel- should I change from the default at all?

JKBurton
November 11th, 2008, 03:12 AM
No doing it from Gnome's volume control isn't the same right now, as there's a known bug where some sound devices don't get shown there.

The way I solved it:
sudo apt-get install gnome-alsamixer

Start playing a music file in Rhythmbox. Make sure Rhythmbox's volume isn't down or muted.

Run Applications/Sound & Video/Gnome ALSA Mixer

Checked every vertical slider, cranking them all up (the horizontal ones are L/R balance). Verify no "mute" boxes are checked. Go to the bottom section of checkboxes turning off any checkboxes that say "External Amplifier" or "Headphone". Repeat on each tab. At some point, hopefully there shall be sound.

You can do the same thing in the text-based alsamixer, but since it doesn't have tabs, it's pretty inconvenient.

Best of luck,
Keith

foxh8er
November 11th, 2008, 02:45 PM
Thanks for the fast service:)

Unfortunately there is still no sound, even though I unmuted everything.

I feel like tearing my hair out:(:(:(

BTW-I have tried different distros on the same pc, and none of them have sound at all-they are Sabayon, PClinuxOS, and Puppy.

I hope that gives someone a clue on what is going on.