View Full Version : [ubuntu] Create FAT32 and ext3 partitions on pendrive

November 9th, 2008, 04:15 PM
I am trying to create 2 partitions on a 8 gig USB pen drive. I want 1 partition FAT32 and 1 ext3 (for quickstart a linux backup program).

I am using gparted from under Hardy Heron. It makes both partitions ok, but i can only read and write to the FAT32, I cant do anything on the ext3 partition.

What have i done wrong?

November 9th, 2008, 04:53 PM
Sounds like it's a permissions issue on the ext3 partition. Since fat32 doesn't do permissions, you wouldn't have a problem there.

chmod 777 partition_name

November 9th, 2008, 05:01 PM
The ext3 partition appears on the desktop if i right click and select permissions it says permissions of "disk1" could not be determined what do i do to fix this

thanks for your help

November 9th, 2008, 05:54 PM
Have you tried "gksu nautilus"?

November 9th, 2008, 07:08 PM
no whats that?

November 9th, 2008, 07:50 PM
You can type it in terminal or after pressing Alt F2.
This might let you change permissions on the flash drive.

November 9th, 2008, 07:53 PM
gksudo nautilus let's you run nautilus as root, that way you might be able to access the ext3 partition, normal users might not have permissions to access it. had that problem on openSuse, I couldn't access my ntfs partitions

November 15th, 2008, 12:42 PM
I also cannot mount an ext3 partition on my pen drive. In my case a 32Gb from Alcor Micro (chinese?). Format to ext3, with or without another FAT32 partition on the pendrive and the system fails to mount with error messages as in attached screenshot. First comes the "Cannot mount Volume", then a minute or so later, the "Unable to Mount Volume".

Suggests using DMESG | TAIL .... the output from which is attached. Suggests system tries to mount first as FAT32, then as ext3, then complains of not finding a valid journal superblock. Not sure what that is, or how to fix it.

I've tried both things suggested so far in this thread: gksu nautilus, and chmod 777 /dev/sdb1 etc... still the same result.

If I reformat to FAT32 it all mounts fine again. But this means I can't use rsync, or Unison properly to create a backup mirror; or use sbackup because of the 4Gb limit on FAT32 filesize.

I was using gParted to partition/format. Tried the gParted forum - suggested it was an error in the Dbus subsystem used by Gnome to manage hotplugging.

Here is the thread: http://gparted-forum.surf4.info/viewtopic.php?id=4913

Which also has some other /etc/fstab, lsusb, and DMESG | /dev/sdb1 outputs.

System Intrepid with latest updates applied.

Any ideas/workarounds?



November 15th, 2008, 03:27 PM
chmod 777 worked for me and I downloaded programs that allowed me to label the partitions as well.

As far as backing up i've gone through loads of posts and programs since i keep my data on ntfs and fat32 disks and partitions.

However i finally came up with the solutuin for a newbie to linux like me its a GUI for rsync called Grsync which seems to back up and sync to anything. You can download from synaptic package manager.

good luck