PDA

View Full Version : [ubuntu] Can't browse Windows Shares from Terastation



ZonComGMZ
November 9th, 2008, 05:49 AM
Hey all,

I am having a problem with Windows shares that I can't figure out for the past three days.

From Ubuntu Intrepid
Can see shares on Vista PCs and can browse, read & write.
Can see shares on TeraStations but can't browse, read or write.

From XP
Can see shares on Vista PCs and can browse, read & write.
Can see shares on TeraStations and can browse, read & write.
Can see shares on Ubuntu Intrepid and can browse, read & write.

From Vista
Can see shares on XP PC and can browse, read & write.
Can see shares on TeraStations and can browse, read & write.
Can see shares on Ubuntu Intrepid and can browse, read & write.

The thing that is throwing me off is I can see it in Network | Windows Network | Terastation Name | Share Name but can't browse the files.

Just for the heck of it I tried looking with other GUI File Managers.
Gnome Commander - Lets me browse the folders and files except the last character of the filename is missing therefore the folders and filenames are wrong.
Dolphin - Crashes upon browse of same folders where filenames are missing last character.

Because this is happening in more than one program (Nautilus) I think it may be a larger problem with Samba.

Any ideas?

Peter09
November 9th, 2008, 10:20 AM
What version of Ubuntu are you running. This was a known problem with Nautilus at one time. Have you upgraded all your apps of late?

kellemes
November 9th, 2008, 10:30 AM
Please post /etc/fstab

ZonComGMZ
November 9th, 2008, 08:54 PM
Please post /etc/fstab

# /etc/fstab: static file system information.
#
# -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
# Entry for /dev/sda1 :
UUID=adee80c5-e8f5-4428-be03-ac2f2e80086e / ext3 relatime,errors=remount-ro 0 1
# Entry for /dev/sda5 :
UUID=321b76a7-68b7-4e2f-839e-dccc2e7b6093 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0

ZonComGMZ
November 10th, 2008, 02:03 PM
I think I may have found a solution. I added this to /etc/fstab and now the shares automount and are browsable in Nautilus without the last character missing.


//Server/Share /home/zoncomgmz/Shares/Home_RA1 smbfs auto,username=????,???,uid=1000,umask=000,user 0 0
//Server/Share /home/zoncomgmz/Shares/Business_RA1 smbfs auto,username=????,password=???,uid=1000,umask=000 ,user 0 0

Once they automount I still can't browse the shares via Nautilus under Network but I can by the Automounted entry with no problems.

Very strange bug and a pain to figure out the fix. Now I have Vista shares on another PC I need to figure out the format for /etc/fstab