View Full Version : [ubuntu] 8.10 Running out of room on 2GB USB stick install

November 7th, 2008, 06:37 PM
To facilitate computer fixings and for the occasional WOWWIES for people who didn't know you *cough*Linux*cough* could do that I've decided to make a bootable usb stick. Right now I'm testing Ubuntu 8.10 using the wonderfully simple directions found here (http://www.pendrivelinux.com/2008/11/01/ubuntu-810-install-using-the-built-in-usb-installer/) and so long as I have a copy of the .ISO file available to install from since using the live CD dies when trying to make the stick bootable, all goes well.

Until I get around to installing the basic packages I want to take with me. I've tried deleting all the useless localization stuff, unwanted packages etc but I still keep running out of space. The root filesystem is full. Granted the sticks only 2GB but what's happened to that extra 1.2GB that is supposed to be used to contain changes? df -h shows various tmpfs enties with around 503MB free but there's no space with 1.2GB or anything close to it. So would I be correct in assuming that it's being used up by any combination of those other tmpfs entries?

And even then, how can I go about making the root file-space where all these apps are being installed a bit larger, even if it leaves me less home-space to carry my firefox settings and such around in, I'd rather that than running out of application space.

I'd hoped it would be as simple as not assigning all the extra 1.2GB of space to the persistent casper-rw loop file but that doesn't seem to be the case since if I set that to say 500MB the root filesystem ends up as full even faster. And looking at the drive itself just shows that there's less space used for the whole setup.

December 7th, 2008, 11:57 PM
Did you ever figure this out? I've installed and reinstalled Ubuntu and Xubuntu several times, but each time it fills up. Even if I uninstall the larger programs like OO. It quickly becomes unusable and doesn't seem to be saving any settings.

December 8th, 2008, 02:01 AM
yes and no...

when you uninstall applications from the Live USB you're not actually uninstalling anything since the apps that come on the Live USB are still in the live section. in fact you're eating up space by having bits of data that say "pretend this isn't installed".

Oddly enough the 1st few times i rebooted on to the Live USB stick i kept getting a static, non-persistent environment. Then all of a sudden it started picking up the persistent command in the boot menu and it shows the rootfs as having however many GB that there should be.

but you're still not actually uninstalling anything. i ended up switching to an 8GB stick since there are a bunch of programs i wanted to add.

I've also noticed inconsistent persistence. Sometimes, usually when using a different computer, the i'll get the desktop i had 1 before the last one i shut down. as in the last session's saved data wasn't saved... or loaded. then when i reboot i'll again get to continue on from the session before last. like it's one step behind. which is really odd.

i've since settled down with the 8GB stick though so haven't mucked about with it much.

December 8th, 2008, 04:31 AM
Thanks man, that's some good info. I've been trying out different methods of installing it, but I'm still having the same problems. It's seems that the USB creator isn't really meant for creating a usable environment, but more for just making an installer. I'm downloading Fedora right now. Maybe I'll have better luck with that. Although, I think 2GB is probably just too small.