View Full Version : [ubuntu] NFS won't automount after upgrade from 8.04 to 8.10

November 5th, 2008, 05:12 PM
Hi folks. Recently upgraded to Ibex from Heron, and before my two NFS shares being served from an ArchLinux machine would automount on boot. But after upgrading they doesn't automount. Can't see anything during the boot messages explaining the NFS not able to mount.
The following two lines show the two lines I've tried without any luck (the first one worked fine in Heron): /files nfs rw 0 0 /files nfs defaults 0 0
Does anyone have any suggestions to solve this problem?

November 6th, 2008, 10:17 PM
I am having the same problem with 2 from 3 machines which I've upgraded from 8.04 to 8.10. On one of the upgraded machines the NFS shares mount at boot, on 2 upgraded machines the shares do not mount at boot. The /etc/fstab entries are the same on all 3 machines. Networking is OK. After logging in a

sudo mount -a
will mount the NFS shares without any complaints. They just don't mount during boot. I cannot find anything in the logs to indicate an error.
BTW, my NFS server is running Ubuntu 8.04 Server.

Any suggestions welcome.

November 9th, 2008, 03:58 PM
I hate saying it, but same here. I did, however, just figure it out while I was typing this message. Edit /etc/init.d/mountall.sh and change

mount -a -t nonfs,nfs4,smbfs,cifs,ncp,ncpfs,coda,ocfs2,gfs,gfs 2

mount -a -t nonfs,nfs,nfs4,smbfs,cifs,ncp,ncpfs,coda,ocfs2,gfs ,gfs2

Note the use of nfs and nfs4. This needs to go in the main line since I have an nfs server configured, not nfs4 yet.

November 10th, 2008, 01:31 AM
Oops, copy and pasto.

mount -a -t nfs,nfs4,smbfs,cifs,ncp,ncpfs,coda,ocfs2,gfs,gfs2

November 27th, 2008, 01:06 PM

ich habe das gleiche problem in ibex, d.h. per automounter übers netz gemountete dateisysteme sind nach einem neustart nicht erreichbar. als workaround habe ich in /etc/rc2.d/S99rc.local

/etc/init.d/autofs reload

eingefügt. danach funktioniert der automounter auch nach dem neustart.