PDA

View Full Version : [ubuntu] 8.10 Intrepid Ibex Nvidia legacy GeForce 2 MX 400



eduardoska
November 4th, 2008, 11:46 PM
I don't know if this has been posted before, but with the new release of the Intrepid Ibex, i found my graphic chipset only worked with the nv driver upgrade from the installation.

I found the way to make it work my chipset with full 3d using the beta driver from nvidia.What i did and worked for me is

1. Downloaded the beta driver from nvidia here the 96.43.09 legacy BETA here (http://www.nvnews.net/vbulletin/showthread.php?t=122139) ( I Used the Nvidia driver 0.run)

2. Downloaded from synaptic manager linux-headers-generic and linux-source-2.6.27


sudo apt-get install linux-headers-generic linux-source-2.6.27

3. CTRL + ALT F1

4.
sudo /etc/init.d/gdm stop

5.
sudo sh NVIDIA DRIVER that you downloaded from the url above

6
sudo /etc/init.d/gdm start and done!

That worked for me

jdmarshall
November 6th, 2008, 01:36 PM
I too, have difficulties with Intrepid, and a GeForce MX460. I will try your proposed fix method this evening.

Thankyou for posting,



Regards,
John

deroby
November 6th, 2008, 02:27 PM
Trying this on a DELL Inspiron 8200 with GeForce4 Go card... fingers crossed... (I took the pkg1.run file though).

Things seem to go well, it needs to recompile a lot of stuff, but there is progress...

Auto-Config ran fine too

NVIDIA package finished without any errors, but when restarting the gdm I'm presented with a black screen.

Using shutdown -now to restart the machine from the console...

(machine seems to hang on the 'going down' screen... waited a while, but in the end simply "pulled the plug")

Machine is rebooting now... but somewhere along the line the progressbar switches to text-mode and shows nvidia [Fail] in the list of err, modules being started.

It then seems to jump back to GUI mode, I hear the 'drums' that I associate with the login screen, however, the screen remains black. I seem to remember having had this with a RIVA TNT laptop on 7.10 too when installing from scratch, so I'll have to search for that one again =( Maybe I should try to hook up an external screen ? Oh well, out of time now, will try to continue on this again sometime later...

Hope this helps / warns anyone else out there with the same setup... (ps : when I come to think of it, maybe I should have removed all other nvidia related packages before I ran that beta NVIDIA*pkg1.run thingie ?)

edit : did sudo apt-get remove nvidia* to get rid of all the nvidia related packages, rebooted and now am kind of stuck with an X-server that complains its unable to start anything, and a gdm stop command that is (apparently) ignored as the NVIDIA package keeps complaining that there is an X-server running... =(
Got around that one by using ctrl-backspace before running the NVIDIA thing

Anyway, reran the NVIDIA package, lots of recompiles again etc, bit of complaining about modified configuration files, but in the end I'm still stuck with a black screen.

eduardoska
November 6th, 2008, 06:23 PM
I chose the pkg0.run package and it worked like a charm :)

And wich Geforce 4 Go card do you have?? The ones supported by this drivers are the next ones:

GeForce4 440 Go 0x0174
GeForce4 420 Go 0x0175
GeForce4 420 Go 32M 0x0176
GeForce4 460 Go 0x0177
GeForce4 440 Go 64M 0x0179

If you indeed have one of those cards, then remember, this drivers are still in beta and they're not in full release yet.

eduardoska
November 6th, 2008, 06:30 PM
Or maybe you can try with this another legacy beta driver, GeForce4 Go chipset it's supported too by this one

http://www.nvnews.net/vbulletin/showthread.php?t=122140

eduardoska
November 6th, 2008, 06:32 PM
Or maybe you can try with this another legacy beta driver, GeForce4 Go chipset it's supported too by this one

http://www.nvnews.net/vbulletin/showthread.php?t=122140

lolcese
November 6th, 2008, 08:20 PM
Worked perfectly, thanks !

deroby
November 6th, 2008, 10:43 PM
I THINK it's a GeForce4 440 Go so it _should_ be supported, it has 64Mb ram so it might be the 64M version ?. I know things are still beta, so you won't hear me complain... just trying out things on my 'toy-laptop'.

I downloaded the pkg0.run using wget <url> (CLI power! =) and ran that one... rebooting as we speak...

No errors, but still black screen...think I'll need to go look that one up in another thread, pretty sure I've had something similar long ago... I'm pretty sure the screen is there, but the back lightning isn't on, hence it doesn't work very comfortable =/

Playing around a bit I decided to hook up an external screen, it immediately complained about an unsupported input : refresh rates H:06kHZ, V:85Hz

Thinking there might be a similar problem with the laptops own display, I went into the /etc/X11/xorg.conf file using emacs and threw out the resolutions 1600x1200 and 1280x<something> although the first one is the actual native resolution of the screen. After saving I (ctrl-c/ctrl-x, took me ages to find, newbie here) I wanted to restart gdm, but somehow messed up and started a second x-server !? And that one worked nicely, shows an nvidia logo during startup, but I can live with that =)

Rebooting AGAIN as we speak, hoping that I will now be able to log into the 'default' GUI (alt-F7), fingers crossed.

Once this works, it will become an issue of finding out how to get the resolution back up again, 1024x768 is a little too low imho.

GRRRR, black screen again =(

And now it even fails all over the place when I try to start gdm =( Oh well, at least I tasted the power of a decent driver for a couple of (precious) seconds =)

Looking around I found nvidia-installer --update ... trying that one now, it downloads a completely different package !?! (177.80)

Funny, once downloaded it comes telling me that the GPU found (Geforce4 440 Go) is supported through 96.43.xx and will be ignored by this package =) Oh well ...

stinger30au
November 6th, 2008, 10:55 PM
thanks for the info i will try it today

if you want to see what video card uses what drivers, this post may help you


http://ubuntuforums.org/showthread.php?t=970237

deroby
November 6th, 2008, 10:55 PM
another update (hope I don't bore you guys to death =)

Found out how to get multiple x-sessions running (simply starting them using /etc/init.d/gdm --? which somehow errors into thinking I want a new one open ?!?

Anyway, that opens up a new one nicely (alt-F8) and running glxgears gives me 1600+ fps, so I guess that I'm no longer running in software mode there =) Setting the appearance to non-basic gives me the wobly-windows, however, it causes text-screens (eg. Terminal) to show up as an empty white canvas =(

Need to get on doing other stuff the next days, but will see if there is an update by then and if the problem persists will try to report it to nvnews. I'm sure we're on the right track here, probably some simple configuration that's wrong, but I'm afraid I'm way too newby to find it on my own =(

Regardless, I think ubuntu is quite an achievement !

eduardoska
November 6th, 2008, 11:28 PM
Im glad i could help you!
If you want to get rid of the NVIDIA logo once you solved all your issues try this on your Xorg.conf

Under devices comment this line

Devices
Driver "nvidia"
NOLOGO "true"

stinger30au
November 7th, 2008, 05:11 AM
Please click one of the Quick Reply icons in the posts above to activate Quick Reply.


this afternoon i upgraded my video card to a nvidia 5500 256M 8x video card, and it works a treat with these drivers as well incase anyone wants to know

mc510
November 7th, 2008, 07:25 PM
will this driver end up in the repositories soon, so that it can be installed through the 'hardware driver' control panel?

eduardoska
November 8th, 2008, 09:47 PM
I guess it will but untill it's the final release not the beta driver

Jeffa
November 8th, 2008, 10:11 PM
do you have to kill gnome to run that script? After i run the command in step four, I just get a black screen with a cursor in the upper left corner.

eduardoska
November 9th, 2008, 04:01 AM
do you have to kill gnome to run that script? After i run the command in step four, I just get a black screen with a cursor in the upper left corner.
you have to kill gnome desktop manager (GDM) it's detailed how to do it,after you press CTRL + F1, it takes you to terminal mode, and here you type


sudo /etc/init.d/gdm stop
once done this, you run the script and then return to gdm typing


sudo /etc/init.d/gdm start

and that's it, it should work after that! At least it worked for me!

eduardoska
November 9th, 2008, 04:04 AM
how do i delete doble posts? lol

wayover13
November 12th, 2008, 03:43 AM
I guess it will but untill it's the final release not the beta driver

From the 8.10 Release Notes:

nVidia "legacy" video support

The 71 and 96 series of proprietary nVidia drivers, as provided by the nvidia-glx-legacy and nvidia-glx packages in Ubuntu 8.04 LTS, are not compatible with the X.Org included in Ubuntu 8.10. Users with the nVidia TNT, TNT2, TNT Ultra, GeForce, GeForce2, GeForce3, and GeForce4 chipsets are affected and will be transitioned on upgrade to the free nv driver instead. This driver does not support 3D acceleration.

So it looks like there is no plan to include nVidia's driver in the ubuntu repositories. Instead users will be expected to use the GPL nv driver.

James

Jeffa
November 12th, 2008, 03:48 AM
From the 8.10 Release Notes:

nVidia "legacy" video support

The 71 and 96 series of proprietary nVidia drivers, as provided by the nvidia-glx-legacy and nvidia-glx packages in Ubuntu 8.04 LTS, are not compatible with the X.Org included in Ubuntu 8.10. Users with the nVidia TNT, TNT2, TNT Ultra, GeForce, GeForce2, GeForce3, and GeForce4 chipsets are affected and will be transitioned on upgrade to the free nv driver instead. This driver does not support 3D acceleration.

So it looks like there is no plan to include nVidia's driver in the ubuntu repositories. Instead users will be expected to use the GPL nv driver.

James

Major drag. I hope this changes in the future. Had I known about this before I upgraded I wouldn't have.

Additionally, I don't recall being asked to switch to the NV driver during the upgrade process.

wayover13
November 15th, 2008, 04:02 AM
Here's an important update. I started to follow these directions and ended up with an nVidia driver without having to follow the link provided by eduardoska, download anything from there, or run any scripts. Unfortunately I can't say which step was decisive in getting an nVidia driver installed on this Intrepid (Mythbuntu) system. I will describe below the steps which I took and that resulted in a working nVidia driver appearing on my system.

I should begin by stating that I have almost the same nVidia card the original poster has (I have GeForce 2 MX 200), so at least part of the steps I took will apply only to cards like or very similar to mine. Perhaps those with other nVidia cards can get this working by apt-get install(ing) the right packages, but I can't offer any first-hand testimonial about that: I can only address what worked on my system.

The first step I took that may have had an effect is to locate and apt-get the package (and its dependencies) nvidia-96-kernel-source (I used aptitude to do this). I fiddled around a bit with the system afterward and then started following eduardoska's steps.

Of the steps he listed, I executed only the first. I.e, I apt-get install(ed) linux-headers-generic linux-source-2.6.27. As those packages were being installed on the system I noted a message indicating that the nVidia driver eduardoska gave a link for was being fetched and installed (96.43.09)--apparently from the Ubuntu repositories. On rebooting the system the gui booted up using the newly-gotten nVidia driver.

Sorry I can't really give a decent step-by-step run down of this. I was actually surprised by what happened since I understood from the release notes that an native nVidia might well never be provided for Intrepid. But I ended up with one one my system and did so by only using apt utilities and Ubuntu repositories. Maybe someone reading this thread and following the steps I did can take careful notes and offer a better report than this one.

Anyway, I'm satisfied with the results I got.

James

noobuntu1337
November 15th, 2008, 10:27 PM
Hi,

I have a GeForce2 MX 200, and I need 3D or 2D acceleration (for player/stage), but cannot install the driver proposed by ubuntu 8.10 via the Hardware/Driver window by clicking on activate. This doesn't really surprise me because it had been announced during the Update.

Does this 96.43.09 thing help at all in this case (the need for 3D/2D acceleration)?

If my english is bad or hard to understand, please tell

Pstevens
November 16th, 2008, 06:53 PM
I don't know if this has been posted before, but with the new release of the Intrepid Ibex, i found my graphic chipset only worked with the nv driver upgrade from the installation.

I found the way to make it work my chipset with full 3d using the beta driver from nvidia.What i did and worked for me is

1. Downloaded the beta driver from nvidia here the 96.43.09 legacy BETA here (http://www.nvnews.net/vbulletin/showthread.php?t=122139) ( I Used the Nvidia driver 0.run)

2. Downloaded from synaptic manager linux-headers-generic and linux-source-2.6.27


sudo apt-get install linux-headers-generic linux-source-2.6.27

3. CTRL + ALT F1

4.
sudo /etc/init.d/gdm stop

5.
sudo sh NVIDIA DRIVER that you downloaded from the url above

6
sudo /etc/init.d/gdm start and done!

That worked for me
Thanks for these. I had to install libc6-dev (using System/Synaptic Package Manager) before I started, or else the compilation didn't work.

Pstevens
November 16th, 2008, 07:00 PM
... but now I've done that, my terminal window comes up as white on white with a white border. In fact my terminal window is just a white square. I have broken 'terminal'. Aaargh!

Pstevens
November 16th, 2008, 07:35 PM
And thanks to this thread
http://ubuntuforums.org/showthread.php?t=934175
I've fixed it:

Alt-F2
metacity --replace

hictio
November 25th, 2008, 04:20 AM
Installed the package 'NVIDIA-Linux-x86-96.43.09-pkg0.run', everything went Ok along the install, ect, etc..
One thing, tough, on 8.04, using the NVIDIA driver on the same card, gave me drop shadow effect out of the box, with this driver, I don't have it, had to enable the Metacity's composite engine to get those.

sbentjies
November 27th, 2008, 11:36 PM
Will this modify the xorg.conf?

hictio
November 28th, 2008, 02:21 AM
Will this modify the xorg.conf?

Yes, it will modify it, but it makes a backup first (and the same installer warns you that it will modify it, ask for your permission to do it, and also informs you that it will create a backups)

Nevertheless, making a backups of your actual one is as simple as opening a Terminal, and typing:



sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.back.before.NVIDIA (ENTER)

bobpaul
November 30th, 2008, 02:27 AM
and will be transitioned on upgrade to the free nv driver instead. This driver does not support 3D acceleration.

So it looks like there is no plan to include nVidia's driver in the ubuntu repositories. Instead users will be expected to use the GPL nv driver.

Or TV output. Though this still doesn't mean it won't re-appear in 9.04 as a final version driver.

Edit: The easiest way seems to be installing envyng. Either install envyng-qt and run it, or envyng-core if you just want the terminal client. A Mini-Howto (http://www.nvnews.net/vbulletin/showpost.php?p=1843244&postcount=6) exists on the nVnews forums.

guitarMan666
April 27th, 2009, 04:18 AM
This fix works wonderfully. However, after restarting X windows will not resize or move unless the window menu must be used first. Compiz is running in this case (by default, it was not explicitly started). The plugins are enabled. Window moving and resizing works if desktop effects are disabled and Metacity is running. Any thoughts?