PDA

View Full Version : [ubuntu] 8.10 Upgrade Random Freezes on Lenovo X61s



LinuxLars
November 3rd, 2008, 09:21 PM
I followed the upgrade instructions and upgraded to 8.10.

Once installed, the system freezes up from time to time with a flashing CAPS lock status icon, and requires a hard reboot.

Any thoughts about how to solve this? Is it a kernel issue?

jerrylamos
November 4th, 2008, 03:55 AM
What graphics hardware does the Lenovo X61 use?
Might be similar to the problem I've been getting with Intel graphics since Aug 13. Excerpting Developers comments from my Launchpad Bug #259385:

"== Desktop effects and Intel 830MG and 845G video cards ==

There is a bug in the intel video driver for the older intel 830 and 845 integrated video cards that are used on laptops like the IBM R30. Desktop effects with compiz will not work on those chips and freeze the system."

From what I've seen on the posts there are a LOT More chips that have symptoms like this.

My workaround is:
Boot in rescue mode
select root shell prompt
sudo apt-get remove compiz
sudo apt-get remove compiz-core
exit
resume

If that works you're O.K. except no special visual effects. If you want to try compiz again, install with Synaptic.

Jerry

spencerb8
November 4th, 2008, 03:58 AM
I did the update and it will not install anything.

Any idea how to get rid of updates?

Thanks!

LinuxLars
November 4th, 2008, 02:31 PM
Jerry,

The Lenovo X61s uses the Intel Mobile Intel GM965 Express.

I didn't have any issues with compiz using 8.04.

Cheers!
Larry

LinuxLars
November 5th, 2008, 10:45 PM
Jerry, you may be on to something.

I did a complete fresh install and disabled Visual Effects, and while it did experience the same freeze, it took almost 7 hours before it froze - way longer than before.

I've removed compiz and compiz-core and restarted. I'll let you know the results shortly.

Thanks!

LinuxLars
November 5th, 2008, 11:11 PM
Nope. Locked up in around 20 minutes. Guess the last test was just lucky.

Does anyone have any other ideas about how to correct this?

LinuxLars
November 8th, 2008, 07:00 PM
Does anyone have any suggestions about what I can provide to help diagnose this?

jbg
November 8th, 2008, 07:04 PM
I have had a similar problem with my desktop after the upgrade. I did a fresh install and it still happened, random freezing....I have gone back to 8.04

gorazdgrof
November 10th, 2008, 08:48 AM
I have a Lenovo N200 3000 notebook (Nvidia 7300). I have been using 8.04 with compiz half a year with NO crash, everything worked OK.

Now I have upgraded to 8.10 and the system freezes regulary with NumLock flashing. I can only turn the switch OFF to shutdown it.

I am going back to 8.04 too ....

LinuxLars
November 10th, 2008, 03:58 PM
gorazdgrof, this may help:

http://ubuntuforums.org/showthread.php?t=968792

------------------------------------------------
System lock-ups with Intel 4965 wireless
The version of the iwlagn wireless driver for Intel 4965 wireless chipsets included in Linux kernel version 2.6.27 causes kernel panics when used with 802.11n or 802.11g networks. Users affected by this issue can install the linux-backports-modules-intrepid package, to install a newer version of this driver that corrects the bug. (Because the known fix requires a new version of the driver, it is not expected to be possible to include this fix in the main kernel package.)
------------------------------------------------

For me, a combination of the 64-bit install on my Lenovo X61s, along with adding intrepid backports to my Software Source, seems to have fixed things.

My system has been up now over 16 hours without a freeze.

Cheers!

LinuxLars
November 10th, 2008, 04:12 PM
16 hours and 52 minutes, then a freeze. Rats.

LinuxLars
November 10th, 2008, 04:23 PM
I misread the "solution" - I thought adding backports to the software source was the fix. In Synpatic Manager, there's also a linux-backports-modules-intrepid. I just installed that. Stay tuned.

gorazdg
November 11th, 2008, 08:11 AM
LinuxLars thank you for a hint !

I have instaled linux-backport-modules yesterday. I hope it will work. Today it is still OK. :guitar:

gorazdg
November 17th, 2008, 09:17 AM
One week on 8.10 without the freeze !!!
The ocasional screen flickering from 8.04 has gone too.. :)

:lolflag:

Dirius
November 17th, 2008, 01:42 PM
Absolutely same problem with Lenovo X60. So is it just by chance a bit less freezing for you now or have you found a solution?

It seems to me that this is not a Lenovo-specific issue. See this http://ubuntuforums.org/showthread.php?t=765510 but I would be very interested in your solution.

Best regards,

Dirius

LinuxLars
November 26th, 2008, 11:01 PM
Any more news on this?

I had to go back to 8.04 (which is working fine).

Any idea 1) how I can help identify the cause, and 2) get notified when it's fixed?

Cheers!