PDA

View Full Version : [ubuntu] Help me get (free) nv driver working



dcroxton
November 3rd, 2008, 08:29 PM
I lost my dual monitor setup when I upgraded to 8.10. I have an on-board Intel video controller & a pci nVidia controller. My card uses the 96.43.05 nvidia driver, which I understand doesn't work with the latest Xorg. THAT'S FINE. I don't need 3d or special performance; I just want to get the free driver working so I can configure my dual-monitor setup. (Also, I can't view the login screen -- it is blank -- in my current setup; I only get logged in because I had auto login turned on.)

Both video controllers work individually. I thought I could grab the settings from Xorg when I used the nvidia controller as the default, but all it says is,

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Not very helpful. It seems there may have been some change to how Xorg is configured now, but I have no understanding of the new process.

I get no errors in Xorg.0.log, just the following line:

(--) PCI: (0@3:0:0) nVidia Corporation NV11DDR [GeForce2 MX200] rev 178, Mem @ 0xde000000/0, 0xc0000000/0, BIOS @ 0x????????/65536

I have xserver-xorg-video-nv installed. "modprobe nv" finds no such module. I even tried setting the nvidia driver to vesa, but that didn't help.

Here is the xorg.conf that formerly worked. I would be grateful for any assistance:



# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "bitmap"
Load "ddc"
# Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
# Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "Device"
Identifier "Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device"
Driver "i810"
BusID "PCI:0:2:0"
VideoRam 150000
EndSection

Section "Device"
Identifier "AGP7100"
Driver "nv"
BusID "PCI:3:0:0"
EndSection

Section "Monitor"
Identifier "XF-9bi"
Option "DPMS"
HorizSync 30-70
VertRefresh 50-160
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "MAG"
ModelName "MAG 720V2"
HorizSync 30-82
VertRefresh 50-70
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device"
Monitor "XF-9bi"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1024x768"
EndSubSection
EndSection

Section "Screen"
Identifier "Default Screen 2"
Device "AGP7100"
Monitor "Monitor1"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1024x768"
EndSubSection
EndSection


Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Default Screen" 0 0
Screen 1 "Default Screen 2" LeftOf "Default Screen"
Option "Xinerama" "On"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

#Section "DRI"
# Mode 0666
#EndSection

Section "ServerFlags"
Option "Xinerama" "true"
EndSection