View Full Version : [ubuntu] [SOLVED] Upgrade Hardy > Intrepid failed (Used the Update manager)

November 3rd, 2008, 11:29 AM
I am now booting into the CLI, and it seems like EVERY program i ever had is gone (Thanks cleaning funktion in the upgrade).

And i heard that some ati grafik cards arent supported anymore or something, i think i got an Intel. At least thats what sysinfo and some command sez.

Is there anyway of getting it to work AND somehow get back my programs?

If that is not possible i will reinstall (backing up my home before of course).

Any help is apreciated!:KS

PS: Developers: Can you fix the "cleaning" thing in the upgrade please? Many people got all their programs removed because it thought they where "obsolete", it even removed some thing the system needed (i think).
Thank you.

PPS: Sorry to everyone if my english is bad, or if i didnt explain it good. My tool that fixes my spelling where in linux, not windows.

November 3rd, 2008, 04:55 PM
If you are talking of cruft remover it is currently being discussed in the bug report related to it, lots of people are unhappy with it since it doesn't do what is says and has a nasty side effect at that.

Anyway, if you still have a command line try running:

sudo apt-get update
sudo apt-get install ubuntu-desktopto see if you can reinstall the desktop packages.

Link to bug report if you're interested (https://bugs.launchpad.net/ubuntu/+source/system-cleaner/+bug/285746)

November 3rd, 2008, 05:28 PM
Im talking about the Upgrade thing in the Update manager, its "Cleaning" part just removed every "Obselete packages" (Wich means: EVERY PROGRAM I HAD).

Will that install firefox, nautilos, etc etc`?

BTW: Im in INTREPID now, but only CLI. Every program is gone.(Even gnome things)

November 3rd, 2008, 05:34 PM
How about fortune? I know it sounds silly, but I just would like to know if only the essentials are there or if you have some "fluff" left.


November 3rd, 2008, 05:38 PM
Hmm, didnt test that.

But i think i dont have that too.

I will test later.

November 3rd, 2008, 05:44 PM
If you don't, there probably is something seriously wrong. Just:

a) Reinstall 8.10
b) Reinstall 8.04

November 3rd, 2008, 05:46 PM
Im waiting for scragars reply, and my plan B is reinstalling 8.10 after backing up my home.

November 3rd, 2008, 05:52 PM
Good idea Backing up the /home folder. Make sure not to save the /home folder, just make sure not to save them as root.

PS scragar has replied, in The BUMP Thread.

November 3rd, 2008, 05:55 PM
I think if apt-get is ubable to install the desktop then the only thing you can do is reinstall, sorry to hear about the bad experience.

EDIT: having now read your post, yes, it will(if it works) reinstall everything seen as a dependency to ubuntu-desktop, which includes firefox, gnome, evolution etc(all the stuff that comes on a freshly installed system).


Yeah, okay.

Thank you all.
If that thing scragar said doesnt work, i will reinstall intrepid. but i will Backup anyway, just in case. ):P


November 3rd, 2008, 05:58 PM
Yer welcome. ;)

November 3rd, 2008, 11:10 PM
fortune doesnt work...

November 3rd, 2008, 11:13 PM
can you tell me if

man apt

November 3rd, 2008, 11:14 PM
can you tell me if

man apt

November 4th, 2008, 12:10 AM
do you have a live cd?

November 4th, 2008, 12:14 AM
i can burn one.

and man works, and apt-get too.

If i copy my entire home folder, with my damn hard drive mounted on that Usb folder in my home, wouldnt that like copy everything i have on the harddrive?.........

Im in the CLI.

I mounted my HARDRIVE on instead of the USB..... On that folder that i just called USB because i wanted.

Damnit i feel so dumb, nobody understands me, or i dont understand you.

So my status is this:
Im in the cli.
I want to install that ubuntu-desktop package.
I want to backup first.
I failed to mount my usb stick and mounted my hard drive instead in a folder in my home, and now i want to know how i undo that/exclude USB folder from the backup, and FINALLY save my backup on my stick.

This is what some command said about my mounted things:
/dev/sda1 > / (sda1 is my harddrive, i think, looks like it.)
/dev/sda1 > /home/noxn/usb
Something like that.

November 4th, 2008, 12:17 AM
oh, ok you are in the cli.


sudo fdisk -l


November 4th, 2008, 12:21 AM
one thing we do is an image of the ubuntu partition before any upgrading. thus if the upgrade fails in any way we can restore the partition to its exact state prior to the upgrade attempt. the easiest tool we've found for this is "partimage" which can be found here: http://www.sysresccd.org/Download.en.php

November 4th, 2008, 09:04 AM
Lewac, i already upgraded, and i dont want to go back to the cli if it fails...

Yes sisco, did you read the whole thread? and at least the post before you?

What does you command do.


Morning everyone, did Noxn solve his problem?

Either way:
To exclude a directory(s) from tar use:
tar -cvf /homeBackup.tar . --exclude=dir1 --exclude=dir2
And to umount your USB drive I think you can run
umount /home/noxn/usbbut honestly if it's not umounting I'd go mad and force it
sudo umount -a -flbut that's not recomended.

That just like solved all my problems...
Gonna do that, but i cant right now.

November 4th, 2008, 09:26 AM
oh, ok you are in the cli.


sudo fdisk -llists storage devices and partitions


mountlists currently mounted partitions.

November 4th, 2008, 10:02 AM
okay, i made a list for me where i copied all commands i need:
(got it here in a TXT)

sudo ifconfig eth0 up
sudo dhclient

umount /home/noxn/usb

cd ## go to home dir if not already in it
sudo tar -cvf /home/Backup.tar . ## back up current folder(the .) to a file called Backup.tar in /home
#with exclude.
sudo tar -cvf /homeBackup.tar . --exclude=dir1 --exclude=dir2

sudo apt-get update
sudo apt-get install ubuntu-desktop

Only thing i need to know now:
Where do i put the backup? if i dont find out what my usb stick is...
Couldnt i burn it with the cli or something?
I want to do backup even before installing ubuntu-desktop, just in case

November 4th, 2008, 12:36 PM
Make the back-up first, then check it's size:

ls -l /home/Backup.tar
Then, provided it's small enough for your pen copy it over:

cp /home/Backup.tar /home/nozn/usb/
I have no idea about how to burn things from the command line unfortunatly, I've always used nautiluses built in option to do it. Sorry I can't help you with that.

November 4th, 2008, 03:48 PM
yeah, but, i still need to mount my usb...

i got no idea which sda to choose

November 4th, 2008, 07:56 PM
Make the backup and copy it on the stick with a live CD.

Not sure if that would work and i cant find my live cd.

November 6th, 2008, 12:37 PM
Hmm, my system doesnt seem to like my usb stick.
Cant mount it, or een find it.

Where could i copy my backup, then?
I mean, if the ubuntu-desktop package doesnt works as good as needed, i maybe need to reinstall... that would delete everything on the HD, so i cant save the backup there...

Any ideas?

November 6th, 2008, 12:56 PM
Hmm, my system doesnt seem to like my usb stick.
Cant mount it, or een find it.

Where could i copy my backup, then?
I mean, if the ubuntu-desktop package doesnt works as good as needed, i maybe need to reinstall... that would delete everything on the HD, so i cant save the backup there...

Any ideas?

i can help you to mount the usb stick if you post the output of:

sudo fdisk -l

dmesg | tail


plug in the stick(and wait a few seconds) before you run the commands.

November 6th, 2008, 12:57 PM
There is a lot to be said for running a liveCD to copy the information, and if all else fails you can always make a new tiny partition to throw the home folder on, which you can later set as your /home partition(really good idea BTW).

November 6th, 2008, 01:47 PM
Sisco, i already tried fdisk once as you said that one time.
and the only thing it listed was my hard drive (yes, the usb stick WAS pluged in)

November 10th, 2008, 10:35 PM
Okay, after days of doing nothing (bad noxn, you are very bad, *Slaps himself*) i finally tried with the ubuntu livecd... i couldnt copy my files.
But i could acces the harddrive.

Any linux distribution that ignores that?


Could i make the TAR file in the CLI in a way its not in my home? and with acces rights? so i could copy it later fromt the livecd...

Thank you all.

November 10th, 2008, 11:46 PM
Have you tried Slax?

November 11th, 2008, 12:07 AM
No, i wanted to try DSL now... or later...

Gonna try now.

November 11th, 2008, 12:16 AM
OOookaaaay... this is weird...

startx in DSL wont work... some error about X server or some file missing...
And on the second try on startx, i got a kernel panic, interrupt handler or something, and not syncyng.

System not responding, had to reset.

I think DSL just bluescreened me...

November 11th, 2008, 12:24 PM
I have two questions.
1) Did it try to write pagefiles or write to a swap partition?
2) Did you check the CD for defects? (MD5sum)

November 11th, 2008, 02:02 PM

Umm, the ubuntu livecd worked fine, except i had no right to get my
And DSL (Damn Small Linux) gave the kernel panic.

didnt understand 1 question

November 11th, 2008, 02:54 PM

I Make a backup in the CLI, then i CHown (or something) my home folder so anyone can acces it, i boot into the livecd (ubuntu) and copy the backup to the stick, chown my home back to original state (just in case it works without reinstall) and then try the ubuntu-desktop package!

Now... how do i do that?

Could anyone tell me the required commands for the chown etc?

November 14th, 2008, 07:58 PM

Made backup and moved it to /home/, so i could copy it via lan to another PC.
I reinstalled.


November 14th, 2008, 08:04 PM
Don't forget to mark this thread as solved.