View Full Version : [all variants] Matrox g450 Dual Head with Ubuntu 8.10

November 3rd, 2008, 12:59 AM

Has anybody managed to get dual-head working in Ubuntu 8.10 with a Matrox g450 card? I had tweaked something together with 8.04 but upon upgrading it no longer works. I just wanted to know if anybody has had any success.

November 4th, 2008, 11:53 AM
Not yet...):P
I'm also interested in a solution...

November 4th, 2008, 01:25 PM
I have the same G450 problem and am also waiting for a solution

November 6th, 2008, 06:38 PM
Same problem here.

Ubuntu 8.04 and 7.10 previously worked with a Benq 22" widescreen and a Belinea 17". I had these running with the Matrox driver, although I did have to set them up as "generic LCD 1680*1050 widescreen" and "generic LCD 1280*1024" to get them to run. Using the actual make and model for each monitor didn't work.

Now on 8.10 it will only run in low graphics mode with the graphics duplicated on both monitors.

Just my 2c.

November 7th, 2008, 09:47 AM
I heard that it is possible to get it working by installing 8.04 and then upgrading to 8.10
Has anybody tried this and had success?

November 10th, 2008, 12:07 PM
Given that I was previously on 8.04 and upgraded to 8.10, I'd say no. ;)

November 15th, 2008, 10:53 AM
I had to downgrade X to 7.3 from ubuntu 8.04. I works now with fine with dual screen. Ask if you want my xorg.conf

November 19th, 2008, 05:51 PM
Yes please. I reverted back to Ubunut 8.04 and it's all working fine, I'd like to go to 8.10 so it would be helpful.



January 22nd, 2009, 04:07 PM

Can you post (or mail) your xorg ? I am trying to set this up.



January 28th, 2009, 08:09 PM
Anyone have any luck getting dual head g450 working yet with 8.10?

I just bought this card along with a wide-screen monitor, now have a single 1920x1080 screen but it would be great to have two.

Downloaded the driver but install.sh doesn't work.

xorg.conf appears to be still default.

how to install the driver???


March 10th, 2009, 07:41 AM
There's a bug that's documented here:

I tried the solution of installing the Hardy Xorg and I got dual head working with my Matrox G450. Here are the instructions...


Man, I wasted hours on this thinking my xorg.conf needed to be tweaked but really there was an underlying bug. ugh.