View Full Version : [ubuntu] 8.10 Many things don't work

November 3rd, 2008, 12:52 AM
I'm on 8.10 and I have a lot of problems. My sound quit working when I upgraded. My sessions quit working when I upgraded, i.e. I have to log into everything over again after logging back in. System/Preferences/Sessions/Options/Remember Currently Running Application has no effect. I've done all the sound debugging, tried everything anyone ever recommended for pulseaudio or alsa. Everything's set up right, nothing's muted, the right drivers for my hardware, (the same one's as before the upgrade), are installed and in memory, all the volumes are up, but no sound.
Before upgrading, and it's the reason I upgraded hoping that things would get better, Openoffice had not worked for several weeks, seg faulting in an openoffice library, but oddly enough Apport, even though it does report other things, doesn't notice the seg fault, I have to be in gdb to see it. Filing a bug report on it just got them to tell me it was an invalid report because it didn't come via apport. The stuff in ~/.openoffice.org2 isn't set up correctly, (I can see it in strace, failing in access just before the seg-fault), but deleting it and letting it try to set up again doesn't help. Deleting openoffice and reinstalling doesn't help.
Also, before upgrading all of my removable stuff quit working, i.e. plugging in a CDROM, DVD, usb flash drive, or SD flash never results in automatic mounting, although I can manually mount. Pushing the button on the cd/dvd to eject quit working at the same time, although I can eject from the command line.
I'm on a Dell inspiron 1420, and I'm thoroughly disgusted. Linux on Ubuntu used to work better for me. When the whole pulseaudio debacle came only it put a bad tasted in my mouth, but I got over it and finally got sound working with pulseaudio. Now, after the upgrade it doen't work with or without it and a lot of other stuff doesn't work:(


November 3rd, 2008, 12:53 AM
If there is so much conflicts you could ttry a fresh install, make sure your /home is seperate partition first to save your settings/files

November 3rd, 2008, 12:55 AM
Why not just do a fresh install of 8.10 and see if everything is working again?

November 3rd, 2008, 01:14 PM
It's always recommended to do a fresh install, and I dont really see the point in upgrading a system which already has so much problems

November 5th, 2008, 07:37 PM
The openoffice problem has gone away. Everything else is still a problem. I don't know if a complete reinstallation would fix it, but I have a LOT of stuff under /usr/local and my home directory which would be blown away via a reinstallation--how I wish the default partitioning of ubuntu offered separate space for boot, home, and /usr/local. I can look into repartitioning it in place, but that wouldn't deal with the issue that the upgrade broke things, (and daily updates broke things), and understanding how that happened so that others with the same problems, (and searches show MANY with the same problems), can also get fixed. So, the openoffice problem is fixed, one down, anyone got any real suggestions on the others?


November 8th, 2008, 08:10 PM
Well, the openoffice problem was an incompatible libstdc++ in /usr/local/lib. usb stuff and sd cards started mysteriously auto-mounting this morning after not working for months. Following a tip from a web site, the sequence

sudo /etc/init.d/alsa-utils stop
sudo alsa force-reload
sudo /etc/init.d/alsa-utils start

will get my audio working (but I have to do it everytime I boot). All without installing from scratch. The only annoying thing is the session information/memory of applications/ not working. Who knows, maybe after a few more updates that will be fixed too!

In general, I'm always against throwing a fresh install at something to cover up a problem. You don't learn anything by doing that.


November 8th, 2008, 09:18 PM
Also, it seems the force start of alsa kills pulseaudio which won't restart afterward saying:

W: ltdl-bind-now.c: Failed to find original dlopen loader.
W: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
W: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
E: alsa-util.c: Error opening PCM device hw:0: Device or resource busy
E: module.c: Failed to load module "module-alsa-sink" (argument: "device_id=0 sink_name=alsa_output.pci_8086_284b_sound_card_0_a lsa_playback_0"): initialization failed.