View Full Version : [ubuntu] [SOLVED] Upgrade to Ibex with a separate /home partition

November 2nd, 2008, 06:51 PM
I've just upgraded to Ibex, but when I boot using new kernel it refuses to mount my /home partition and complains about bad blocks. At the same time my older kernel works fine. Does anyone know what can it be?

November 2nd, 2008, 09:26 PM
Here is a screenshot of the error:

[img=http://img87.imageshack.us/img87/6144/img0491io7.th.jpg] (http://img87.imageshack.us/my.php?image=img0491io7.jpg)[img=http://img87.imageshack.us/images/thpix.gif] (http://g.imageshack.us/thpix.php)

and here is the log which is mentioned in the error report:

Log of fsck -C3 -R -A -a
Sun Nov 2 15:13:33 2008

fsck 1.41.3 (12-Oct-2008)
/dev/hda2: clean, 59014/2807040 files, 1109903/5604676 blocks

Sun Nov 2 15:13:33 2008

November 3rd, 2008, 05:58 AM
It is even more weird then I thought. If I run fdisk -l in recovery mode it shows all my partitions as /dev/sda while in my fstab they are all /dev/hda:

# /etc/fstab: static file system information.
# -- This file has been automaticly generated by ntfs-config --
# <file system> <mount point> <type> <options> <dump> <pass>

/# /etc/fstab: static file 0 0
proc /proc proc defaults 0 0
# Entry for /dev/hda1 :
UUID=5460ae15-424a-48ec-9e57-7c1e93a13687 / ext3 defaults,errors=remount-ro,relatime 0 1
# Entry for /dev/hda5 :
UUID=2dbdcf1a-5c60-491f-91ee-3dcfc372f34b none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto,exec 0 0
/dev/hda3 /media/windows ntfs-3g defaults,locale=en_CA.UTF-8 0 0
/dev/hda2 /home ext3 nodev,nosuid,relatime 0 2

Any ideas?

November 6th, 2008, 10:11 PM
Ok, i solved this one vy just changing hda to sda in fstab :) but now my wireless driver is missing