PDA

View Full Version : [ubuntu] 8.10 upgrade leaves mouse keyboard not working



nmltom
November 2nd, 2008, 04:04 PM
I am a newbie and need some help. Upgraded 6.06 to 8.04 to 8.10 following the instructions and everything seemed to go fine. However, when it was all over the mouse and keyboard did not function at the GDM login screen.

I can go to terminal mode and keyboard works fine. Looking for a solution, I did run command "dpkg -reconfigure -phigh xerver-xorg" and got the error message "package x-xerver.org is not installed"

I also tried command from another thread "sudo apt-get install xserver-xorg-input-all" and the command ran but did not get the devices working again. I also restarted the computer. Still mouse and kbd do not work.

I would be grateful for any advice that will help me fix the x-server.org file and get the kbd and mouse working again. Thank you.

sbinkerd1
November 2nd, 2008, 04:46 PM
same here. no keyboard and mouse after upgrade.

sbinkerd1
November 2nd, 2008, 11:13 PM
screw 8.10.

After spending all day trying as many different fixes from hours of googling I have decided to give up and copy everything to my 2nd HDD and reinstall hardy. I ended up screwing up the system even more doing the "fixes" and work arounds.

Thanx to the folks at Ubuntu for Hardy. A hex on you for putting out that piece of crap Ibex.

nmltom
November 3rd, 2008, 02:49 AM
So I guess I am not the only one who has this problem. Still I think the solution should be really simple. Can anyone in the Ubuntu community help?

zackiv31
November 3rd, 2008, 02:53 AM
My Keyboard and mouse have been horrific.. trying to figure out if its a GNOME issue or IBEX... got this has been miserable.

SavvyPlayer
November 3rd, 2008, 08:52 PM
I can confirm this is an issue with my upgrade from 7.10 to 8.04 to 8.10.

SavvyPlayer
November 3rd, 2008, 09:45 PM
Reconfiguring (dpkg-reconfigure xserver-xorg) results in an xorg.conf file that contains a bare minimum of detail:

# Usual comments...

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection


That's it. This is something of a crash course in xserver configuration for me, and it would seem the xserver is not recognizing any of the various xserver-xorg-* driver packages that are installed. (I do have all of them installed.)

AUAD
November 3rd, 2008, 10:15 PM
I had this problem to.

I have configured the kernel boot options in my /boot/grub/menu.lst by adding "acpi=off".

More details see here:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/117899

SavvyPlayer
November 3rd, 2008, 11:52 PM
Thanks but disabling acpi does not appear to resolve this issue.

SavvyPlayer
November 4th, 2008, 01:20 AM
Solved this problem by performing another apt-get dist-upgrade. Apparently the first upgrade was not successful -- although it had completed without indicating any of the usual sorts of problems (broken, incomplete packages, etc). Hope this helps others in the thread.

fastpakr
November 4th, 2008, 07:14 AM
How are you guys using dpkg or doing a dist upgrade? When 8.10 finishes coming up for me (8.10 amd64) I can't get to a console with Ctrl-Alt-F2, Ctl-Alt-Bkspc, or any other shortcut I can think of.

nmltom
November 4th, 2008, 09:17 AM
I tried this but it did not help in my case. I ran command "sudo apt-get dist-upgrade" from the command line but nothing ran. I am wondering how I go back one version to 8.04 without damaging my data.

atterdag
November 4th, 2008, 02:53 PM
OK the problem is because mouse and keyboard have been disabled in /etc/X11/xorg.conf:


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

# commented out by update-manager, HAL is now used
#Section "InputDevice"
# Identifier "Generic Keyboard"
# Driver "kbd"
# Option "XkbRules" "xorg"
# Option "XkbModel" "pc105"
# Option "XkbLayout" "se"
# Option "XkbOptions" "lv3:ralt_switch"
#EndSection

# commented out by update-manager, HAL is now used
#Section "InputDevice"
# Identifier "Configured Mouse"
# Driver "mouse"
# Option "CorePointer"
#EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nv"
Option "NoLogo" "True"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
EndSection
Section "Module"
Load "glx"
EndSection

So just remove hashes from the InputDevice sections, and it will work again.

Now what I don't get is, what compelled Canonical to pick such a dodgy way to configure X? o_O

HAL is not yet stable enough to allow something as crucial as keyboard and mouse to be dependent of it. !%&&%#

I'm sorry to say so, but its very RedHat'ish way of distributing Linux. And Canonical really shoot themselves in the foot with this decision.

nmltom
November 4th, 2008, 05:51 PM
Thank you for the suggestion to edit the xorg.conf file. I did that and actually had to add back in the sections for the mouse, keyboard and server layout, as they were absent completely from xorg.conf. When I did that, I got my keyboard function back again, but for some reason not the mouse, which still does not move at all when I reboot and get to the GDM login screen. Does anyone have any further suggestions for where I can look to see why my mouse still does not work? I will appreciate any help. I got stuff to do and need that mouse!

fastpakr
November 4th, 2008, 06:32 PM
I've tried the suggested changes to Xorg.conf (by using a live cd to access and edit the file). I'm still booting with no keyboard or mouse. What concerns me the most is that I'm not convinced it's an Xserver issue - if that were the case, shouldn't I be able to use Ctl-Alt-BkSpc to kill the session? So far it seems like the kernel isn't communicating with the devices, rather than just the X session.

atterdag
November 4th, 2008, 10:56 PM
With the InputDevices disabled in X, I couldn't use Ctrl+Alt+Backspace either. (Which is rather odd when you think about it)

If you have a SSH server running on the box, then try to ssh into it, and stop GDM:

# /etc/init.d/gdm stop

That should bring down the GUI and leave you with a text console. If you're then not able to type anything on the text console. Then you have a fundamental problem with your keyboard and Linux communication.

SanHolo
November 5th, 2008, 12:06 PM
Same problem here, stuck at "System Configuration" with no keyboard (but "ctrl + alt + delete" halts the system and "ctrl + alt + F2" drops me to a console where the keyboard works) and no mouse. apt-get dist-upgrade does nothing, uncommenting keyboard and mouse in xorg.conf does not help, either.

Let's dig some more...

SanHolo
November 5th, 2008, 12:36 PM
uncommenting keyboard and mouse in xorg.conf does not help, either.
Me stupid, I didn't uncomment the final "InputDevice 'mouse'" stuff at the bottom. It now works again!

Alajjana
November 5th, 2008, 05:31 PM
Solved this problem by performing another apt-get dist-upgrade. Apparently the first upgrade was not successful -- although it had completed without indicating any of the usual sorts of problems (broken, incomplete packages, etc). Hope this helps others in the thread.

This was exactly my problem as well. Not only did i have to do the apt-get dist-upgrade from command but also from the gui after i got the keyboard, mouse, and video working....

After the system gets started make sure you check your xorg.log file menu>>system>>admin>>system as GLX and DRI had to be installed as well.

DaGrimReefah
February 25th, 2009, 05:20 AM
Adding this to the end of my xorg.conf did it for me:


Section "ServerFlags"
Option "AutoAddDevices" "false"
EndSection

Although, it disabled hotplugging for my mouse and keyboard. But oh well, as long as they work.

xhabih
August 22nd, 2009, 07:05 AM
Adding this to the end of my xorg.conf did it for me:


Section "ServerFlags"
Option "AutoAddDevices" "false"
EndSectionAlthough, it disabled hotplugging for my mouse and keyboard. But oh well, as long as they work.

Works for me!
Tanks.

ggpauly
April 27th, 2010, 03:54 AM
Section "ServerFlags"
Option "AutoAddDevices" "false"
EndSectionIt

This got gnome working, thanks..

It took 12 hours to upgrade from 8.04 to 8.10 on my Desktop (actually an old IBM server)

Not a shining success for me or canonical, but I appreciate the help here.

In a few days I'll upgrade to to 10.04 - hope this goes easier.

dockulma
July 19th, 2010, 10:32 PM
I was not able to login to my 8.10 upgrade since my keyboard and mouse were not functional. Well, I am a real newbie here but I accidentally was able to login. Let me explain.

I cleaned my cd/dvd writer since it would not read the cd or dvd that I created with Ubuntu 10.04. I then attempted to reboot my system with the 10.04 dvd in the cleaned drive. The dvd was not read and I proceeded to the login page for 8.10. Of course I was not able to use my keyboard or mouse. The front panel was off of my computer since I had removed and then re-installed my dvd player. I proceeded to snap the front panel into place, and in so doing I inadvertently pressed the eject buttons on my cd and dvd player. As this happened, my monitor screen flashed and lo and behold, I was able to type in my login name and my password. My mouse was also working.

This is probably the most un-technical fix I have ever experienced but I am now updating to 9.04 as I type this from a different computer.

I just wanted to share this unorthodox fix that worked for me.