PDA

View Full Version : [ubuntu] Full screen flash video in Firefox - screensaver popping up



1awesomeguy
November 2nd, 2008, 01:53 PM
Every time I play videos on websites like hulu.com in full screen mode, my screensaver pops up. I then need t get up off my bed and move the mouse (oh the drama... I know, but every ten minutes gets annoying). I can change my screensaver settings to to make it only go off after 120 minutes or more, but then I feel as there is almost no point to the screensaver.

Any suggestions or is this a technical issue with my computer?

Thanks in advanced.

mikeym
January 6th, 2009, 03:13 PM
Hi, I'm having exactly the same issue.

I found this thread (http://ubuntuforums.org/showthread.php?p=6318328#post6318328) but I would like it to work without a manual 'fix'.

Any ideas out there?

mikeym
January 6th, 2009, 03:14 PM
Sorry double post!

lodp
February 15th, 2009, 06:58 PM
I agree, this is annoying. Is this an issue with the Adobe Flash Player? Other applications seem to be able to suppress the screen saver just fine, when running full-screen.

1awesomeguy
October 8th, 2009, 03:29 PM
Many months later, I still have not been able to find a good solution to this problem. Hopefully the new Ubuntu will fix it automatically :)

erilidon
December 16th, 2009, 12:35 AM
This is still an issue in 9.10, and I would like to see something done about it as well. Like you said the main time it is annoying is when watching videos on hulu. This is a matter of the mouse just not being moved, not a flash application issue and someone earlier had asked.

I remember having some issues with this while running windows 95 and some one had come up with a program that would make the computer think someone was moving the mouse or pressing a key on the keyboard every few mins, it worked.

But I think the simplest way would be to somehow tell the computer not to turn on the screen saver if a full screen app is running, or for me just if flash is running.

lodp
December 16th, 2009, 12:53 AM
But I think the simplest way would be to somehow tell the computer not to turn on the screen saver if a full screen app is running, or for me just if flash is running.

That's what's happening if you play a video full-screen in some application other than flash (like mplayer or vlc). It suppresses the screen saver. Flash doesn't.

Does anybody have a clue what package we have to file a bug for to get this fixed? I've known the problem since back in '06 when I switched to ubuntu.. it just never received any attention.

Dennis N
December 16th, 2009, 01:20 AM
You can set the time before screensaver kicks in.

System > Preferences > Screensaver

Adjust slider at: "Regard the computer as idle after:" to the desired number of minutes (probably want an hour or more).

lodp
December 16th, 2009, 01:29 AM
Yeah.. but you lose a lot of the energy saving potential by having the setting that high. I think 5-10min is a typical good value. I hardly have the computer idle for longer than 45min - I set it to sleep or switch it off in those cases.

I suspect that flashplayer is just missing a feature that other media players have (i.e. the ability to communicate with the screensaver and prevent it from being triggered when playing fullscreen).

Charkel
December 23rd, 2009, 03:06 PM
This is still an issue in 9.10, and I would like to see something done about it as well. Like you said the main time it is annoying is when watching videos on hulu. This is a matter of the mouse just not being moved, not a flash application issue and someone earlier had asked.

I remember having some issues with this while running windows 95 and some one had come up with a program that would make the computer think someone was moving the mouse or pressing a key on the keyboard every few mins, it worked.

But I think the simplest way would be to somehow tell the computer not to turn on the screen saver if a full screen app is running, or for me just if flash is running.

Yup still an issue :( Same thing with auto sleep of display.
Someone should write some script that automatically moves the mouse a few pixels every 9 minutes :) (I would but I'm not familiar with Linux programming)

Seamyst
December 31st, 2009, 04:04 PM
I have this problem with VLC in Karmic, too.

alopex
July 10th, 2010, 11:04 PM
I realize this is an old thread, but this affects me too using Ubuntu Lucid Lynx 10.04. This bug made me turn off my screensaver: not the optimal/desired solution at all!
I can confirm that this bug only appears in the flashplayer's fullscreen mode.
Does anybody know whether this is a bug in GNOME or in flashplayer? Where can I file a bug report?

/alopex

erilidon
July 11th, 2010, 12:36 AM
I realize this is an old thread, but this affects me too using Ubuntu Lucid Lynx 10.04. This bug made me turn off my screensaver: not the optimal/desired solution at all!
I can confirm that this bug only appears in the flashplayer's fullscreen mode.
Does anybody know whether this is a bug in GNOME or in flashplayer? Where can I file a bug report?

/alopex

I too have resorted to turning the screensaver off all together. I just fond this, but have not yet tried it

http://www.ubuntu-inside.me/2009/03/howto-disable-screen-saver-while-flash.html

alopex
July 11th, 2010, 09:39 AM
It says

Before the start, you should know that, this is not only for youtube video, this is for all kind of flash including the advertisements.So do not forget to close firefox or be sure there is no flash at that page before going out etc : )

Quite a dirty hack in that case. But the comments suggest different solutions. Please let me know if that workaround worked for you.

Meanwhile, I found this bug report on Adobe from November 2008. That bug report doesn't seem to get any attention at all.
https://bugs.adobe.com/jira/browse/FP-997

I wasn't able to find a GNOME bug report on this and I still wonder whether this is an issue in the flashplayer itself or in the GNOME screensaver. Maybe someone can help on this?

/alopex

erilidon
July 25th, 2010, 08:25 PM
It says


Quite a dirty hack in that case. But the comments suggest different solutions. Please let me know if that workaround worked for you.

Meanwhile, I found this bug report on Adobe from November 2008. That bug report doesn't seem to get any attention at all.
https://bugs.adobe.com/jira/browse/FP-997

I wasn't able to find a GNOME bug report on this and I still wonder whether this is an issue in the flashplayer itself or in the GNOME screensaver. Maybe someone can help on this?

/alopex


It couldn't get it to work correctly. Just kept the screensaver off all together - even when I was done watching flash movies. I don't see it as a solution, does the same thing as disabling the screensaver manually.

I have switched my main computer to Windows 7 now - for this and the fact that Linux does not have good silverlight support which is needed for netflix.

I would be more interested in ubuntu if these were added. Let me know if you do find a fix for the flash issue though as I still run ubuntu on my laptops.

lodp
July 25th, 2010, 08:32 PM
Yeah. This bug or 'missing feature' has annoyed me since 2005 when I first ran ubuntu. At this point I'm just waiting for Flash to die.

Here's something that might cheer you up:

http://imgs.xkcd.com/comics/command_line_fu.png

ytsurk
August 7th, 2010, 10:20 PM
run this command in the terminal


gnome-screensaver-command -i

or even add it to your panel,
right click
add custom application launcher
choose type applicaiton in terminal
name it,
type the command in there
choose a nice icon !

exactt
November 10th, 2010, 04:58 PM
Just for the record:

https://bugs.launchpad.net/ubuntu/+source/flashplugin-nonfree/+bug/120896